summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2017-06-16 08:59:06 +0000
committerThomas Weißschuh2017-06-16 08:59:06 +0000
commit9b1835f9681e848d611479fca0111d14d425b5ca (patch)
tree9f143cf3f770be559aeebcc77952e0802c849d2f
parent7fa52e180e4dbbd2bd4ae950e2a9fd62f9c72728 (diff)
downloadaur-9b1835f9681e848d611479fca0111d14d425b5ca.tar.gz
upgpkg: lumail2 3.0-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02fdf63db813..60a9152ad758 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Jun 16 08:59:06 UTC 2017
pkgbase = lumail2
pkgdesc = Console-based mail-client with integrated Lua scripting support
- pkgver = 2.9
+ pkgver = 3.0
pkgrel = 1
url = https://lumail.org
arch = i686
@@ -10,10 +12,9 @@ pkgbase = lumail2
depends = gmime
depends = file
depends = perl
- source = https://lumail.org/download/lumail-2.9.tar.gz
- source = https://lumail.org/download/lumail-2.9.tar.gz.asc
- validpgpkeys = D516C42B1D0E3F854CAB97231909D4080C626242
- sha256sums = 4c0b2a6c0c8958fad261ca1a3ab1ab14822e484182821c1a23db0c16172dd1e6
+ source = https://lumail.org/download/lumail-3.0.tar.gz
+ source = https://lumail.org/download/lumail-3.0.tar.gz.asc
+ sha256sums = 1754c27e15799113293d9d5354a5771a621452b9abddf301c81b31112853ab18
sha256sums = SKIP
pkgname = lumail2
diff --git a/PKGBUILD b/PKGBUILD
index 2c59297c9430..1e286472885f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,35 @@
pkgname=lumail2
-pkgver=2.9
+pkgver=3.0
pkgrel=1
pkgdesc="Console-based mail-client with integrated Lua scripting support"
arch=('i686' 'x86_64')
url="https://lumail.org"
license=('GPL')
depends=('lua' 'gmime' 'file' 'perl')
+_LVER=lua53
+_LUA_VERSION=5.3
source=("https://lumail.org/download/lumail-$pkgver.tar.gz"{,.asc})
validpgpkeys=('D516C42B1D0E3F854CAB97231909D4080C626242') # Steve Kemp
-sha256sums=('4c0b2a6c0c8958fad261ca1a3ab1ab14822e484182821c1a23db0c16172dd1e6'
+sha256sums=('1754c27e15799113293d9d5354a5771a621452b9abddf301c81b31112853ab18'
'SKIP')
build() {
cd lumail-$pkgver
- make LUA_VERSION=5.3 LVER=lua
+ make LUA_VERSION=$_LUA_VERSION LVER=$_LVER
}
check() {
cd lumail-$pkgver
- ./lumail2 --test
+ make LUA_VERSION=$_LUA_VERSION LVER=$_LVER test test-lua
+}
+
+prepare() {
+ cd lumail-$pkgver
+ # fix installation, see https://github.com/lumail/lumail/pull/308
+ sed -i '/if there is an old config/,+1d' Makefile
}
package() {
cd lumail-$pkgver
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" LUA_VERSION=$_LUA_VERSION LVER=$_LVER install
}