summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2017-10-16 10:17:54 +0200
committerThomas Weißschuh2017-10-16 10:17:54 +0200
commitebd9f5816a598c87b96ad748adde95a543793b92 (patch)
tree1d5833007224ca1c7d07d94b729a2d58b8df73d5
parent9b1835f9681e848d611479fca0111d14d425b5ca (diff)
downloadaur-ebd9f5816a598c87b96ad748adde95a543793b92.tar.gz
upgpkg: lumail2 3.1-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--16c437fd68119c645c615032c40415bdedccd1f9.patch104
-rw-r--r--PKGBUILD15
3 files changed, 123 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60a9152ad758..821037105a5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 16 08:59:06 UTC 2017
+# Mon Oct 16 08:17:54 UTC 2017
pkgbase = lumail2
pkgdesc = Console-based mail-client with integrated Lua scripting support
- pkgver = 3.0
+ pkgver = 3.1
pkgrel = 1
url = https://lumail.org
arch = i686
@@ -12,9 +12,11 @@ pkgbase = lumail2
depends = gmime
depends = file
depends = perl
- source = https://lumail.org/download/lumail-3.0.tar.gz
- source = https://lumail.org/download/lumail-3.0.tar.gz.asc
- sha256sums = 1754c27e15799113293d9d5354a5771a621452b9abddf301c81b31112853ab18
+ source = 16c437fd68119c645c615032c40415bdedccd1f9.patch
+ source = https://lumail.org/download/lumail-3.1.tar.gz
+ source = https://lumail.org/download/lumail-3.1.tar.gz.asc
+ sha256sums = 67379a546c86e72aad51e2ce266ab37c79fab19f95fe67a1a575c635ca261582
+ sha256sums = 8497a8b1028001df684c7fce2820898a30fb39938a467216477c5401dcb9476e
sha256sums = SKIP
pkgname = lumail2
diff --git a/16c437fd68119c645c615032c40415bdedccd1f9.patch b/16c437fd68119c645c615032c40415bdedccd1f9.patch
new file mode 100644
index 000000000000..0a1f4a6020ab
--- /dev/null
+++ b/16c437fd68119c645c615032c40415bdedccd1f9.patch
@@ -0,0 +1,104 @@
+From 16c437fd68119c645c615032c40415bdedccd1f9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ji=C5=99=C3=AD=20Klime=C5=A1?= <blueowl@centrum.cz>
+Date: Thu, 31 Aug 2017 15:28:50 +0200
+Subject: [PATCH] Makefile: fix Makefile installation (re-introduce DESTDIR)
+
+make install should not hardcode installation locations, but rather allow
+alternative locations. Not only it allows users to install to their
+preferred place, but also makes the installation process work for distribution
+packaging.
+
+This has been originally implemented in f2ff8bbe58509a69291aff7c7ee05fe1e12905d7,
+but broken recently by 3cdf26a0ff1ee289e09c9bc36538c68d46eb8ee5.
+---
+ Makefile | 43 +++++++++++++++++++++++--------------------
+ 1 file changed, 23 insertions(+), 20 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2faa4b8..f4a5d7a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -27,6 +27,18 @@
+ VERSION=$(shell git describe --abbrev=4 --dirty --always --long)
+
+ #
++# Install locations
++#
++DESTDIR?=
++PREFIX?=/usr
++SYSCONFDIR?=/etc
++LUMAIL_ETC?=$(DESTDIR)$(SYSCONFDIR)/lumail
++LUMAIL_HOME?=$(DESTDIR)$(PREFIX)/share/lumail
++LUMAIL_LIBS?=$(DESTDIR)$(PREFIX)/lib/lumail
++LUMAIL_HOME_OLD?=$(DESTDIR)$(SYSCONFDIR)/lumail2
++LUMAIL_LIBS_OLD?=${LUMAIL_HOME_OLD}/lib
++
++#
+ # Load the flags if they're not already set - first look at the version
+ #
+ LUA_VERSION?=5.2
+@@ -106,7 +118,6 @@ LINKER=$(CC) -o
+ #
+ # Compilation flags and setup for packages we use.
+ #
+-LUMAIL_LIBS=/usr/lib/lumail/
+ CPPFLAGS+=-std=c++0x -Wall -Werror
+ CPPFLAGS+=-DLUMAIL_VERSION="\"${VERSION}\"" -DLUMAIL_LUAPATH="\"${LUMAIL_LIBS}\""
+ CPPFLAGS+=${LUA_FLAGS} $(shell pcre-config --cflags) $(shell pkg-config --cflags ncursesw) $(shell pkg-config --cflags gmime-2.6)
+@@ -224,23 +235,16 @@ test-lua: lumail2
+ # Cleanup obsolete versions of our IMAP code
+ #
+ clean_imap:
+- rm /etc/lumail2/perl.d/delete-message || true
+- rm /etc/lumail2/perl.d/get-folders || true
+- rm /etc/lumail2/perl.d/get-messages || true
+- rm /etc/lumail2/perl.d/save-message || true
+- rm /etc/lumail2/perl.d/set-flags || true
+- rm /etc/lumail2/perl.d/imap-proxy || true
+- rm /etc/lumail2/perl.d/Lumail.pm || true
+- rmdir /etc/lumail2/perl.d || true
++ rm -rf $(LUMAIL_HOME_OLD)/perl.d/
+
+
+ #
+ # Install the IMAP proxy beneath /usr/share/lumail
+ #
+ install_imap: clean_imap
+- mkdir -p /usr/share/lumail || true
+- install -m755 perl.d/imap-proxy /usr/share/lumail/
+- install -m644 perl.d/Lumail.pm /usr/share/lumail/
++ mkdir -p $(LUMAIL_HOME) || true
++ install -m755 perl.d/imap-proxy $(LUMAIL_HOME)
++ install -m644 perl.d/Lumail.pm $(LUMAIL_HOME)
+
+
+ #
+@@ -248,11 +252,11 @@ install_imap: clean_imap
+ # configuration-file, in case the user has editted it.
+ #
+ install_lua:
+- mkdir -p /usr/lib/lumail || true
+- install -m644 lib/*.lua /usr/lib/lumail
+- mkdir -p /etc/lumail/ || true
+- mv /etc/lumail/lumail.lua /etc/lumail/lumail.lua.$$(date +%d-%m-%Y.%s) || true
+- install -m644 ./global.config.lua /etc/lumail/lumail.lua
++ mkdir -p $(LUMAIL_LIBS) || true
++ install -m644 lib/*.lua $(LUMAIL_LIBS)
++ mkdir -p $(LUMAIL_ETC) || true
++ mv $(LUMAIL_ETC)/lumail.lua $(LUMAIL_ETC)/lumail.lua.$$(date +%d-%m-%Y.%s) || true
++ install -m644 ./global.config.lua $(LUMAIL_ETC)/lumail.lua
+
+
+ #
+@@ -260,9 +264,8 @@ install_lua:
+ # the Lua libraries and perl proxy.
+ #
+ install: lumail2 install_imap install_lua
+- mkdir -p /usr/bin || true
+- install -m755 lumail2 /usr/bin/
+-
++ mkdir -p $(DESTDIR)$(PREFIX)/bin || true
++ install -m755 lumail2 $(DESTDIR)$(PREFIX)/bin/
+
+
+ #
diff --git a/PKGBUILD b/PKGBUILD
index 1e286472885f..55781f59810a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=lumail2
-pkgver=3.0
+pkgver=3.1
pkgrel=1
pkgdesc="Console-based mail-client with integrated Lua scripting support"
arch=('i686' 'x86_64')
@@ -8,9 +8,13 @@ license=('GPL')
depends=('lua' 'gmime' 'file' 'perl')
_LVER=lua53
_LUA_VERSION=5.3
-source=("https://lumail.org/download/lumail-$pkgver.tar.gz"{,.asc})
+source=(
+ 16c437fd68119c645c615032c40415bdedccd1f9.patch
+ "https://lumail.org/download/lumail-$pkgver.tar.gz"{,.asc}
+)
validpgpkeys=('D516C42B1D0E3F854CAB97231909D4080C626242') # Steve Kemp
-sha256sums=('1754c27e15799113293d9d5354a5771a621452b9abddf301c81b31112853ab18'
+sha256sums=('67379a546c86e72aad51e2ce266ab37c79fab19f95fe67a1a575c635ca261582'
+ '8497a8b1028001df684c7fce2820898a30fb39938a467216477c5401dcb9476e'
'SKIP')
build() {
@@ -27,6 +31,11 @@ prepare() {
cd lumail-$pkgver
# fix installation, see https://github.com/lumail/lumail/pull/308
sed -i '/if there is an old config/,+1d' Makefile
+
+ patch < "${srcdir}/16c437fd68119c645c615032c40415bdedccd1f9.patch"
+
+ # https://github.com/lumail/lumail/issues/327
+ sed -i '/image\/png/d' t/test.mime.lua
}
package() {