summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Bertelli2022-08-25 21:47:50 -0300
committerFilipe Bertelli2022-08-25 21:47:50 -0300
commit9473bc7ad4664d6a55e336fcbc9b17aeb03198fe (patch)
tree5055914c51a2946eda1f170b7bef1572f5a2b683
parent41813e852de6990233b71555f796832022c3da72 (diff)
downloadaur-9473bc7ad4664d6a55e336fcbc9b17aeb03198fe.tar.gz
Update to 0.9.4 and added support for arm64
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58ccfa100e50..ebc7f4d503ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = lumi
pkgdesc = A Desktop App that offers a collection of tools to create, edit and share digital content with your class.
- pkgver = 0.9.1
+ pkgver = 0.9.4
pkgrel = 1
url = https://lumi.education
arch = x86_64
+ arch = aarch64
license = GPL3
depends = gtk3
depends = nss
depends = nodejs
+ depends = alsa-lib
options = !emptydirs
- source = lumi-0.9.1.pacman::https://github.com/Lumieducation/Lumi/releases/download/v0.9.1/lumi-0.9.1.pacman
- sha256sums = cc259090478ae638089bf5d145783c92f8a3c0af55e05c8195bec10a6fbf4929
+ source_x86_64 = lumi-x86_64-0.9.4.pacman::https://github.com/Lumieducation/Lumi/releases/download/v0.9.4/lumi-0.9.4.pacman
+ sha256sums_x86_64 = f0c1123ba6628e9c05ad3278e2eade31e262d05319fb523ce72a73b1d4d82e04
+ source_aarch64 = lumi-aarch64-0.9.4.pacman::https://github.com/Lumieducation/Lumi/releases/download/v0.9.4/lumi-0.9.4-aarch64.pacman
+ sha256sums_aarch64 = a9294445b817d1fd2102959c48e500022079d8e56d599668871a82bfe6ce2ecd
pkgname = lumi
diff --git a/PKGBUILD b/PKGBUILD
index f35d97fc9521..de4b63ea05d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: ValHue <vhuelamo at gmail dot com>
-#
+# Maintainer: Filipe Bertelli <filipebertelli@tutanota.com>
# Contributor: ValHue <vhuelamo at gmail dot com>
-#
+
pkgname="lumi"
-pkgver="0.9.1"
-pkgrel="1"
+pkgver=0.9.4
+pkgrel=1
pkgdesc="A Desktop App that offers a collection of tools to create, edit and share digital content with your class."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://${pkgname}.education"
_url="https://github.com/Lumieducation/Lumi"
license=('GPL3')
-depends=('gtk3' 'nss' 'nodejs')
+depends=('gtk3' 'nss' 'nodejs' 'alsa-lib')
#makedepends=('')
options=('!emptydirs')
-source=("${pkgname}-${pkgver}.pacman::${_url}/releases/download/v${pkgver}/lumi-${pkgver}.pacman")
-sha256sums=('cc259090478ae638089bf5d145783c92f8a3c0af55e05c8195bec10a6fbf4929')
+source_x86_64=("${pkgname}-x86_64-${pkgver}.pacman::${_url}/releases/download/v${pkgver}/lumi-${pkgver}.pacman")
+source_aarch64=("${pkgname}-aarch64-${pkgver}.pacman::${_url}/releases/download/v${pkgver}/lumi-${pkgver}-aarch64.pacman")
+sha256sums_x86_64=('f0c1123ba6628e9c05ad3278e2eade31e262d05319fb523ce72a73b1d4d82e04')
+sha256sums_aarch64=('a9294445b817d1fd2102959c48e500022079d8e56d599668871a82bfe6ce2ecd')
package() {
install -d "${pkgdir}/{opt,usr}"