summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorE5ten2018-05-10 00:14:32 -0400
committerE5ten2018-05-10 00:14:32 -0400
commit0ac9d9dfd0a0f67e6e424f5e6823285bed5587c6 (patch)
tree4f4809dac3fc1a43f8a9a02355ec5e067707e28f
downloadaur-0ac9d9dfd0a0f67e6e424f5e6823285bed5587c6.tar.gz
initial
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6459533234b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lumina-calculator
+ pkgdesc = Screenshot tool for the lumina desktop environment
+ pkgver = 1.4.0p1
+ pkgrel = 1
+ url = https://github.com/trueos/lumina
+ arch = x86_64
+ license = BSD
+ makedepends = qt5-base
+ makedepends = qt5-svg
+ makedepends = qt5-tools
+ provides = lumina-screenshot
+ conflicts = lumina-desktop
+ conflicts = lumina-desktop-git
+ conflicts = insight-fm
+ source = https://github.com/trueos/lumina/archive/v1.4.0-p1.tar.gz
+ sha512sums = 340079832f4f6c9c9c70f11d7743b7c7db6772897f6411a966bf2bd77124bab1fbac8f5751164fb8a08a12c4443f515aaee76b117b4f959263eeaa98dbcbe41e
+
+pkgname = lumina-calculator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b11d8689d8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: E5ten
+
+pkgname=lumina-calculator
+_pkgver=1.4.0-p1
+pkgver=1.4.0p1
+pkgrel=1
+pkgdesc="Screenshot tool for the lumina desktop environment"
+arch=('x86_64')
+url='https://github.com/trueos/lumina'
+license=('BSD')
+depends=()
+makedepends=('qt5-base' 'qt5-svg' 'qt5-tools')
+conflicts=("lumina-desktop" "lumina-desktop-git" "insight-fm")
+provides=("lumina-screenshot")
+source=("https://github.com/trueos/lumina/archive/v${_pkgver}.tar.gz")
+sha512sums=('340079832f4f6c9c9c70f11d7743b7c7db6772897f6411a966bf2bd77124bab1fbac8f5751164fb8a08a12c4443f515aaee76b117b4f959263eeaa98dbcbe41e')
+
+build() {
+ cd "${srcdir}/lumina-${_pkgver}/src-qt5/desktop-utils/$pkgname"
+ qmake QMAKE_CFLAGS_ISYSTEM= PREFIX="/usr" LIBPREFIX=/usr/lib QT5LIBDIR=/usr/lib/qt CONFIG+=WITH_I18N L_MANDIR=/usr/share/man L_ETCDIR="/etc"
+ make
+}
+
+package() {
+ cd "${srcdir}/lumina-${_pkgver}/src-qt5/desktop-utils/$pkgname"
+ make INSTALL_ROOT="${pkgdir}" install
+} \ No newline at end of file