summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChad Sharp2016-08-09 16:20:23 -0400
committerChad Sharp2016-08-09 16:20:23 -0400
commit74e246ed9f81479df0c2de5507efb38a9e4f5f77 (patch)
treea957cf9070cbdca687d1da55f628dc6cab48ec2a
parent43b124a35ffa02e36b27c5c81a04742bf4dccd69 (diff)
downloadaur-74e246ed9f81479df0c2de5507efb38a9e4f5f77.tar.gz
Updated to Release-p1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 933e98b159da..513836f33871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Feb 19 23:23:38 UTC 2016
+# Tue Aug 9 20:20:20 UTC 2016
pkgbase = lumina-desktop
pkgdesc = A Lightweight QT5 Desktop for FreeBSD
- pkgver = 0.8.8
- pkgrel = 1
- url = https://github.com/pcbsd/lumina
+ pkgver = 1.0.0
+ pkgrel = 0
+ url = https://github.com/trueos/lumina
install = lumina.install
arch = x86_64
arch = i686
@@ -34,8 +34,8 @@ pkgbase = lumina-desktop
conflicts = lumina-de-git
conflicts = lumina-desktop-git
conflicts = insight-fm
- source = https://github.com/pcbsd/lumina/archive/v0.8.8-Release-p1.tar.gz
- md5sums = 449332ea59ff55cc1bfcc1a2c5edf1e2
+ source = https://github.com/trueos/lumina/archive/v1.0.0-Release-p1.tar.gz
+ md5sums = 37c4f2d5d87f28f05db82678a7630ac9
pkgname = lumina-desktop
diff --git a/PKGBUILD b/PKGBUILD
index bc64703c27fa..c89e9746eb76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Chad "crossroads1112" Sharp <crossroads1112@riseup.net>
pkgname=lumina-desktop
-pkgver=0.8.8
-pkgrel=1
+pkgver=1.0.0
+pkgrel=0
my_pkgrel=Release-p1
pkgfullname="${pkgname%-*}-${pkgver}-${my_pkgrel}"
pkgdesc="A Lightweight QT5 Desktop for FreeBSD"
arch=('x86_64' 'i686')
-url="https://github.com/pcbsd/lumina"
+url="https://github.com/trueos/lumina"
license=('BSD')
depends=('qt5-base' 'qt5-svg' 'qt5-multimedia' 'qt5-x11extras' 'fluxbox' 'oxygen' 'oxygen-icons' 'xscreensaver' 'desktop-file-utils' 'qtchooser')
optdepends=('xorg-xbacklight: required for changing screen brightness' 'alsa-utils: required for adjusting audio volume' 'acpi: required for monitoring battery life' 'numlockx: required for changign state of numlock at login' 'pavucontrol: required for detatched audio mixer' 'fluxmod-styles: A good set of Fluxbox themes to improve the appearence of window decorations' 'network-manager-applet: Manage network connections from panel' 'xterm: Terminal emulator')
@@ -14,20 +14,19 @@ makedepends=('qt5-base' 'qt5-tools')
conflicts=("lumina-de-git" "lumina-desktop-git" "insight-fm")
provides=("${pkgname%-*}" "insight-fm")
install="${pkgname%-*}.install"
-source=("https://github.com/pcbsd/lumina/archive/v${pkgver}-${my_pkgrel}.tar.gz")
-md5sums=('449332ea59ff55cc1bfcc1a2c5edf1e2')
+source=("https://github.com/trueos/lumina/archive/v${pkgver}-${my_pkgrel}.tar.gz")
+md5sums=('37c4f2d5d87f28f05db82678a7630ac9')
build(){
- cd $srcdir/${pkgfullname}
- $srcdir/${pkgfullname}/libLumina/make-linux-distro.sh Debian
+ cd "$srcdir/${pkgfullname}"
find $srcdir/${pkgfullname} -name *.desktop -exec sed -i 's/usr\/local/usr/' {} \;
- qmake-qt5 PREFIX="/usr" QT5LIBDIR=/usr/lib/qt
+ qmake-qt5 QMAKE_CFLAGS_ISYSTEM= PREFIX="/usr" QT5LIBDIR=/usr/lib/qt
make
}
package() {
- cd $srcdir/"${pkgfullname}"
+ cd "$srcdir/${pkgfullname}"
make INSTALL_ROOT="${pkgdir}" install
mv "${pkgdir}"/usr/etc "${pkgdir}"/etc
}