summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwapnil Devesh2023-07-01 11:23:30 +0530
committerSwapnil Devesh2023-07-01 11:23:30 +0530
commitd7040df8ddfad267524a240802deb0fd3e3fe4c1 (patch)
treef1ad044db3483f3c4e68db2aca697dcf5b797df5
parentfa1d674bc071719f5ceb7c87950e5bb68c5d30c4 (diff)
downloadaur-d7040df8ddfad267524a240802deb0fd3e3fe4c1.tar.gz
Handle submodule
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 288a27f3e180..a8bfbc2ae16a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,16 @@ makedepends=('git')
depends=('gtk3' 'ddcutil')
provides=("$pkgname")
conflicts=("$pkgname")
-source=("git+https://github.com/sidevesh/$_pkgname.git")
+source=("git+https://github.com/sidevesh/$_pkgname.git" "git+https://github.com/ahshabbir/ddcbc-api.git")
sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.ddcbc-api.url "$srcdir/ddcbc-api"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
cd "$srcdir/$_pkgname"
./build.sh