summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Baum2018-04-02 05:17:06 +0200
committerDavid Baum2018-04-02 05:17:06 +0200
commit94ad8737542c71e21de6d386300d3e73aee7ea7a (patch)
treeeb29925dca17b3fd1cf2ba0ddf4d953028459f1b
downloadaur-94ad8737542c71e21de6d386300d3e73aee7ea7a.tar.gz
initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a2ee9585842
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = luminance-git
+ pkgdesc = Luminance is a Philips Hue client for Linux written in Python and GTK+
+ pkgver = 21
+ pkgrel = 1
+ url = https://github.com/craigcabrey/luminance
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = autoconf
+ makedepends = python
+ makedepends = python-requests
+ makedepends = gtk3
+ makedepends = pygobject-devel
+ depends = python
+ depends = dconf
+ depends = hicolor-icon-theme
+ source = git+https://github.com/craigcabrey/luminance.git
+ md5sums = SKIP
+
+pkgname = luminance-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..261c94a48d89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: David Baum <david.baum@naraesk.eu>
+pkgname=luminance-git
+pkgver=21
+pkgrel=1
+pkgdesc="Luminance is a Philips Hue client for Linux written in Python and GTK+"
+arch=('any')
+url="https://github.com/craigcabrey/luminance"
+license=('GPL2')
+groups=()
+depends=('python' 'dconf' 'hicolor-icon-theme')
+makedepends=('git' 'autoconf' 'python' 'python-requests' 'gtk3' 'pygobject-devel')
+optdepends=()
+provides=()
+conflicts=('')
+replaces=()
+backup=()
+options=()
+install=()
+changelog=()
+source=('git+https://github.com/craigcabrey/luminance.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd luminance
+ git rev-list --count HEAD
+}
+
+build() {
+ cd luminance
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd luminance
+ make DESTDIR="$pkgdir/" install
+}