summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsim Bera2021-10-31 13:10:27 +0530
committerAsim Bera2021-10-31 13:30:00 +0530
commitacc778a4ff418318cc8c67aa145ded4f17840756 (patch)
tree1ad319efaa38fe4e7ff62691cbfa598fc57060c1
downloadaur-acc778a4ff418318cc8c67aa145ded4f17840756.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7789e5c645fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lunacy-bin
+ pkgdesc = Free design software that keeps your flow with AI tools and built-in graphics
+ pkgver = 8.0.4.0
+ pkgrel = 1
+ url = https://icons8.com/lunacy
+ arch = x86_64
+ license = custom: commercial
+ depends = gcc-libs
+ depends = hicolor-icon-theme
+ depends = zlib
+ depends = fontconfig
+ provides = lunacy
+ source_x86_64 = lunacy_x86_64_8.0.4.0.deb::https://lun-eu.icons8.com/s/setup/Lunacy_8.0.4.0.deb
+ sha256sums_x86_64 = a24930c161a5e5ea67c2e90e4c19bf7414e2b0b94ece17d633a4f1d380ddd387
+
+pkgname = lunacy-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59ff2432e698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Asim Bera <asimbera at outlook dot in>
+
+# Check for new releases in: https://docs.icons8.com/release-notes/
+
+pkgname=lunacy-bin
+_pkgname=lunacy
+pkgver=8.0.4.0
+pkgrel=1
+pkgdesc="Free design software that keeps your flow with AI tools and built-in graphics"
+arch=('x86_64')
+url="https://icons8.com/lunacy"
+license=('custom: commercial')
+depends=('gcc-libs' 'hicolor-icon-theme' 'zlib' 'fontconfig')
+provides=('lunacy')
+
+source_x86_64=(lunacy_x86_64_${pkgver}.deb::https://lun-eu.icons8.com/s/setup/Lunacy_${pkgver}.deb)
+sha256sums_x86_64=('a24930c161a5e5ea67c2e90e4c19bf7414e2b0b94ece17d633a4f1d380ddd387')
+
+package() {
+ echo " -> Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s /opt/icons8/${_pkgname}/Lunacy "${pkgdir}"/usr/bin/lunacy
+}