summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzlsun2016-05-20 17:22:59 +0800
committerzlsun2016-05-20 17:22:59 +0800
commitb5ec78431e69e969fabd8caac1b6187b6c8b99ff (patch)
treeedb73a4aedb3db9a0202db4afaf33306e27876cd
downloadaur-b5ec78431e69e969fabd8caac1b6187b6c8b99ff.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cba44972d16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri May 20 09:22:48 UTC 2016
+pkgbase = lunar-calendar-git
+ pkgdesc = Chinese Lunar calendar widget for Gtk+
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://code.google.com/p/liblunar/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = gobject-introspection
+ depends = gtk3>=3.0.9
+ depends = lunar-date>=2.4.0
+ provides = lunar-calendar
+ conflicts = lunar-calendar
+ source = git+https://github.com/yetist/lunar-calendar.git
+ sha256sums = SKIP
+
+pkgname = lunar-calendar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b702d8cdbfea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zlsun <zlsun1995 at gmail dot com>
+# Contributor: yetist <yetist@gmail.com>
+
+pkgname=lunar-calendar-git
+_pkgname=lunar-calendar
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Chinese Lunar calendar widget for Gtk+"
+arch=("i686" "x86_64")
+url="http://code.google.com/p/liblunar/"
+license=('GPL2')
+depends=('gtk3>=3.0.9' 'lunar-date>=2.4.0')
+makedepends=('git' 'gnome-common' 'gobject-introspection')
+conflicts=('lunar-calendar')
+provides=('lunar-calendar')
+source=("git+https://github.com/yetist/$_pkgname.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install || return 1
+}
+