summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirect-A2021-11-04 21:11:20 +0800
committerDirect-A2021-11-04 21:14:39 +0800
commit4d9a1afddd7bf73a165e19144eed5c124188beac (patch)
tree82b9dd21d992a29beb933228a4d4b731d71eb1c6
parent9c3fceb170facd1cc70425b4d91bf79f230572f6 (diff)
downloadaur-4d9a1afddd7bf73a165e19144eed5c124188beac.tar.gz
fix: `config.example-no-ts.lua` is not exist, change
to `config.example.lua` change: beautty `init-lvim.sh` output
-rw-r--r--PKGBUILD10
-rwxr-xr-xinit-lvim.sh14
2 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 048cfc5f5179..acd1dd9486ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lunarvim-git
pkgver=0.5.1.r388.ge05ced8e
-pkgrel=1
+pkgrel=2
pkgdesc="An IDE layer for Neovim with sane defaults. Completely free and community driven."
arch=('any')
url='https://github.com/LunarVim/LunarVim'
@@ -18,11 +18,9 @@ depends=(
'nodejs'
'yarn')
makedepends=('git')
-optdepends=(
- 'ripgrep: optional dependencies for telescope.nvim')
+optdepends=('ripgrep: optional dependencies for telescope.nvim')
install=${pkgname}.install
-langs=(
- bash beancount bibtex
+langs=(bash beancount bibtex
c c_sharp clojure cmake comment commonlisp cpp css cuda
dart devicetree dockerfile dot
elixir erlang
@@ -48,7 +46,7 @@ source=("${pkgname}::git+https://github.com/LunarVim/LunarVim.git#branch=rolling
"lvim")
sha256sums=('SKIP'
'SKIP'
- '3d7be8c2534a15e502ca0f925d1c0c10454371c0bc584941e15265da10fb1e82'
+ 'a47395027a6754183bb3c72dc7720a35887dc4b6535bf59a9728f49389e70a49'
'bf8a977a1ceff5240e5709de79f0eb2543816f2d627d6a750e766a78bc28d503')
pkgver() {
diff --git a/init-lvim.sh b/init-lvim.sh
index 87a70120dada..1a11296809a9 100755
--- a/init-lvim.sh
+++ b/init-lvim.sh
@@ -1,10 +1,10 @@
#!/bin/bash
mkdir -p ~/.config/lvim
-ln -s /usr/share/doc/lunarvim/config.example-no-ts.lua ~/.config/lvim/config.lua
+cp /usr/share/doc/lunarvim/config.example.lua ~/.config/lvim/config.lua
mkdir -p ~/.local/share/lunarvim
ln -s /usr/share/lunarvim ~/.local/share/lunarvim/lvim
-echo "Installing dependencies of NodeJS & Rust..."
+echo -e "\033[1;32m==> Installing dependencies of NodeJS & Rust...\033[0m"
npm install -g neovim
npm install -g tree-sitter-cli
yarn global add neovim
@@ -12,24 +12,24 @@ yarn global add tree-sitter-cli
cargo install fd-find
cargo install ripgrep
-echo "Installing Packer..."
+echo -e "\033[1;32m==> Installing Packer...\033[0m"
git clone https://github.com/wbthomason/packer.nvim ~/.local/share/lunarvim/site/pack/packer/start/packer.nvim
-echo "PackerInstall..."
+echo -e "\033[1;32m==> PackerInstall...\033[0m"
lvim --headless +'autocmd User PackerComplete sleep 100m | qall' +PackerInstall
-echo "PackerSync..."
+echo -e "\033[1;32m==> PackerSync...\033[0m"
lvim --headless +'autocmd User PackerComplete sleep 100m | qall' +PackerSync
rm ~/.config/lvim/config.lua
cp /usr/share/doc/lunarvim/config.example.lua ~/.config/lvim/config.lua
-echo "Installing treesitter parsers.."
+echo -e "\033[1;32m==> Installing treesitter parsers..\033[0m"
ln -s /usr/share/lunarvim/prebuild/nvim-treesitter/parser/* \
~/.local/share/lunarvim/site/pack/packer/start/nvim-treesitter/parser/
ln -s /usr/share/lunarvim/prebuild/nvim-treesitter/parser-info/* \
~/.local/share/lunarvim/site/pack/packer/start/nvim-treesitter/parser-info/
-echo "Generate the new ftplugin template files.."
+echo -e "\033[1;32m==> Generate the new ftplugin template files..\033[0m"
lvim --headless +LvimUpdate +q
echo