summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2021-08-09 14:00:18 +0800
committeredward-p2021-08-09 14:00:18 +0800
commit654acd6361a535d1bf85662b18f40dd48eaf0261 (patch)
treecd017cb1b6dbb874dacd0f34b7fc45be7d3c92ae
parente6a7feedc61d7568fc84dc7b4b2994cab5951266 (diff)
downloadaur-654acd6361a535d1bf85662b18f40dd48eaf0261.tar.gz
lunarvim-git: optimizes
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rwxr-xr-xinit-lvim.sh2
-rwxr-xr-xlvim2
4 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b498a05a7145..cd924faee2a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,21 +10,20 @@ pkgbase = lunarvim-git
depends = neovim
depends = lua
depends = git
- depends = ripgrep
depends = fzf
depends = neovim-remote
- depends = neovim-plenary-git
depends = tree-sitter
depends = python-pynvim
depends = nodejs
depends = yarn
+ optdepends = ripgrep: optional dependencies for telescope.nvim
source = lunarvim-git::git+https://github.com/LunarVim/LunarVim.git#branch=rolling
source = git+https://github.com/nvim-treesitter/nvim-treesitter.git#branch=0.5-compat
source = init-lvim.sh
source = lvim
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 481874f766e0eee893569f327a16c2decb0bc1cbd3536d985aa2964e494db562
- sha256sums = cfaa30e851dad37d89c131db0b76d3b2f74961933c109e462c710aab8e78defa
+ sha256sums = 0bb4e331e3e47dab1610b04b1a2bcdf96a56f8880ef5cbf00ee0f3b1bd8c4873
+ sha256sums = 9a28e9aa6555fb34432b00db18e0d89cfa34370201168377e20f09c0da64dc08
pkgname = lunarvim-git
diff --git a/PKGBUILD b/PKGBUILD
index 2840e91d3667..d4a103d816d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,16 @@ depends=(
'neovim'
'lua'
'git'
- 'ripgrep'
'fzf'
'neovim-remote'
- 'neovim-plenary-git'
'tree-sitter'
'python-pynvim'
'nodejs'
'yarn')
makedepends=('git')
+optdepends=(
+ 'ripgrep: optional dependencies for telescope.nvim'
+)
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/LunarVim/LunarVim.git#branch=rolling"
"git+https://github.com/nvim-treesitter/nvim-treesitter.git#branch=0.5-compat"
@@ -27,8 +28,8 @@ source=("${pkgname}::git+https://github.com/LunarVim/LunarVim.git#branch=rolling
"lvim")
sha256sums=('SKIP'
'SKIP'
- '481874f766e0eee893569f327a16c2decb0bc1cbd3536d985aa2964e494db562'
- 'cfaa30e851dad37d89c131db0b76d3b2f74961933c109e462c710aab8e78defa')
+ '0bb4e331e3e47dab1610b04b1a2bcdf96a56f8880ef5cbf00ee0f3b1bd8c4873'
+ '9a28e9aa6555fb34432b00db18e0d89cfa34370201168377e20f09c0da64dc08')
pkgver() {
cd "${pkgname}"
diff --git a/init-lvim.sh b/init-lvim.sh
index e49703501c3a..75a120b6271c 100755
--- a/init-lvim.sh
+++ b/init-lvim.sh
@@ -1,6 +1,8 @@
#!/bin/bash
mkdir -p ~/.config/lvim
ln -s /usr/share/doc/lunarvim/config.example-no-ts.lua ~/.config/lvim/config.lua
+mkdir -p ~/.local/share/lunarvim
+ln -s /usr/share/lunarvim ~/.local/share/lunarvim/lvim
echo "Installing Packer..."
git clone https://github.com/wbthomason/packer.nvim ~/.local/share/lunarvim/site/pack/packer/start/packer.nvim
echo "PackerInstall..."
diff --git a/lvim b/lvim
index a73ee19c5358..5a1d917a2a5d 100755
--- a/lvim
+++ b/lvim
@@ -1,3 +1,3 @@
#!/bin/sh
-exec nvim -u /usr/share/lunarvim/init.lua --cmd "set runtimepath+=/usr/share/lunarvim" "$@"
+exec nvim -u '~/.local/share/lunarvim/lvim/init.lua' --cmd 'set runtimepath+=~/.local/share/lunarvim/lvim' "$@"