summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlastair Cooper2022-09-24 18:22:08 +0100
committerAlastair Cooper2022-09-24 18:22:08 +0100
commitdbda8ee84bb2107d60649c9afcc1381ad6e33756 (patch)
treee8659dc81eea320c18df8258bc709b1f35cdd87a
downloadaur-dbda8ee84bb2107d60649c9afcc1381ad6e33756.tar.gz
lunatask 1.5.7
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8872b75305c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lunatask
+ pkgdesc = unofficial third-party Arch package for lunatask.app (*not* supported by Lunatask developers)
+ pkgver = 1.5.7
+ pkgrel = 0
+ url = https://lunatask.app
+ arch = x86_64
+ license = custom
+ depends = gconf
+ depends = libindicator-gtk3
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ options = !strip
+ source = https://lunatask.app/download/Lunatask-1.5.7.AppImage
+ sha256sums = 5703075c7f2cef90d51c47f2eaf17fc6fd45122377e11fef3e0267a90fe63409
+
+pkgname = lunatask
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5a76a233670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alastair Cooper <alastair@alastair87.me>
+pkgname='lunatask'
+pkgver=1.5.7
+pkgrel=0
+pkgdesc='unofficial third-party Arch package for lunatask.app (*not* supported by Lunatask developers)'
+arch=('x86_64')
+depends=('gconf' 'libindicator-gtk3' 'libappindicator-gtk3' 'libnotify' 'libxss' 'libxtst' )
+url='https://lunatask.app'
+license=('custom')
+
+_file=Lunatask-${pkgver}.AppImage
+source=(https://lunatask.app/download/${_file})
+sha256sums=('5703075c7f2cef90d51c47f2eaf17fc6fd45122377e11fef3e0267a90fe63409')
+
+options=('!strip')
+
+prepare() {
+ # Extract AppImage contents so we install bypassing every and all AppImage
+ # desktop integration/deployment mechanisms
+ chmod +x "${_file}"
+ "./${_file}" --appimage-extract &>/dev/null
+}
+
+package() {
+ install -d "$pkgdir"/usr/bin/
+ install -d "$pkgdir"/usr/local/lunatask/
+ install -d "$pkgdir"/usr/share/applications/
+ install -d "$pkgdir"/usr/share/icons/
+ install -d "$pkgdir"/usr/share/icons/hicolor/512x512/apps
+
+ install -m644 squashfs-root/usr/share/icons/hicolor/512x512/apps/lunatask.png "$pkgdir"/usr/share/icons/hicolor/512x512/apps/lunatask.png
+
+ sed -i 's/Exec=AppRun --no-sandbox %U/Exec=lunatask/' squashfs-root/lunatask.desktop
+ install -m644 squashfs-root/lunatask.desktop "$pkgdir"/usr/share/applications/
+
+ find squashfs-root -type d -exec chmod 755 {} +
+ mv squashfs-root/* "$pkgdir"/usr/local/lunatask/
+ ln -s /usr/local/lunatask/lunatask "$pkgdir"/usr/bin/lunatask
+}