summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:06:00 -0400
committerKyle Keen2015-06-13 00:06:00 -0400
commite617f268116744e28f95df1e92dccaa50bbcd59d (patch)
treed51f212e17fb6bd9ceaefb69addca075adefd738
downloadaur-e617f268116744e28f95df1e92dccaa50bbcd59d.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62edf2fcd376
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lunchbox
+ pkgdesc = An innovative (and beta) hybrid floating/tiling WM.
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = http://code.google.com/p/lunchbox/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = cairo
+ depends = libxcursor
+ source = http://lunchbox.googlecode.com/files/lunchbox_0.3-3.tar.gz
+ md5sums = accb26993329f919560f0dee19224653
+
+pkgname = lunchbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f84534ad12e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Kyle Keen <keenerd@gmail.com>
+pkgname=lunchbox
+pkgver=0.3.3
+_fullver=0.3-3 # bleh dashes in version
+_tarver=0.3 # why!
+pkgrel=1
+pkgdesc="An innovative (and beta) hybrid floating/tiling WM."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/lunchbox/"
+license=('GPL3')
+depends=('cairo' 'libxcursor')
+source=("http://$pkgname.googlecode.com/files/${pkgname}_${_fullver}.tar.gz")
+md5sums=('accb26993329f919560f0dee19224653')
+
+build() {
+ cd "$srcdir/${pkgname}-${_tarver}"
+ install -d "$pkgdir/usr/bin" # makefile bug
+ rm themes/.lunchbox # symlink to author's home
+ sed -i 's|/local/lunchbox|/share/lunchbox|' theme.c # source does not care about datadir
+ make datadir=/usr/share
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${_tarver}"
+ make DESTDIR="$pkgdir" datadir=/usr/share install
+}
+