summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCompey2023-07-23 17:32:44 +0530
committerCompey2023-07-23 17:32:44 +0530
commit09ffe285ae15b2e2dc022ea5ffe56563318b7c8a (patch)
tree90d87a3d8804fb86a0b6315f9e9a2ba5c35f2131
downloadaur-09ffe285ae15b2e2dc022ea5ffe56563318b7c8a.tar.gz
chore(release): AUR lune v0.7.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20ee543185ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lune
+ pkgdesc = PRECOMPILED - A standalone Luau script runtime
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://github.com/filiptibell/lune
+ arch = x86_64
+ arch = aarch64
+ license = MPL
+ provides = lune
+ conflicts = lune-git
+ source_x86_64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-x86_64.zip
+ sha256sums_x86_64 = eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c
+ source_aarch64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-aarch64.zip
+ sha256sums_aarch64 = dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd
+
+pkgname = lune
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e0b35b36dcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Erica Marigold <hi@devcomp.xyz>
+pkgname=lune
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="PRECOMPILED - A standalone Luau script runtime"
+arch=('x86_64' 'aarch64')
+url="https://github.com/filiptibell/lune"
+license=('MPL')
+provides=('lune')
+conflicts=('lune-git')
+source_x86_64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-x86_64.zip")
+source_aarch64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-aarch64.zip")
+sha256sums_x86_64=('eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c')
+sha256sums_aarch64=('dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mv "$srcdir/lune" "$pkgdir/usr/bin"
+}