summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCompey2023-07-28 14:43:08 +0530
committerCompey2023-07-28 14:43:08 +0530
commit33416c28e51399327ac78bb7f01aebd4d03c74fc (patch)
tree060e884c969ed7f7bce7641999949f2b868918d0
parent09ffe285ae15b2e2dc022ea5ffe56563318b7c8a (diff)
downloadaur-33416c28e51399327ac78bb7f01aebd4d03c74fc.tar.gz
chore: cleanup & repurpose PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 38 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20ee543185ef..d4142a3de181 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = lune
- pkgdesc = PRECOMPILED - A standalone Luau script runtime
+ pkgdesc = [Latest Stable Source] A standalone Luau script runtime
pkgver = 0.7.5
pkgrel = 1
- url = https://github.com/filiptibell/lune
+ url = https://lune-org.github.io/docs
arch = x86_64
arch = aarch64
- license = MPL
- provides = lune
+ license = MPL2
+ makedepends = cargo
conflicts = lune-git
- source_x86_64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-x86_64.zip
- sha256sums_x86_64 = eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c
- source_aarch64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-aarch64.zip
- sha256sums_aarch64 = dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd
+ conflicts = lune-bin
+ options = !lto
+ source = lune-0.7.5.tar.gz::https://github.com/filiptibell/lune/archive/refs/tags/v0.7.5.tar.gz
+ sha256sums = e8191df5d6844026772cc7afab1083235a265c506474c4c4dee0a7724b04f775
pkgname = lune
diff --git a/PKGBUILD b/PKGBUILD
index 4e0b35b36dcc..c655c7463e3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,37 @@
# Maintainer: Erica Marigold <hi@devcomp.xyz>
+
pkgname=lune
pkgver=0.7.5
pkgrel=1
-pkgdesc="PRECOMPILED - A standalone Luau script runtime"
-arch=('x86_64' 'aarch64')
-url="https://github.com/filiptibell/lune"
-license=('MPL')
-provides=('lune')
-conflicts=('lune-git')
-source_x86_64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-x86_64.zip")
-source_aarch64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-aarch64.zip")
-sha256sums_x86_64=('eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c')
-sha256sums_aarch64=('dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd')
+pkgdesc="[Latest Stable Source] A standalone Luau script runtime"
+arch=(x86_64 aarch64)
+conflicts=(lune-git lune-bin)
+url="https://lune-org.github.io/docs"
+license=(MPL2)
+makedepends=(cargo)
+options=(!lto)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/filiptibell/lune/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('e8191df5d6844026772cc7afab1083235a265c506474c4c4dee0a7724b04f775')
+
+prepare() {
+ cd "lune-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "lune-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd lune-${pkgver}
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features -- --test-threads 1 || (EC=$?; if [ $EC -ne 0 ]; then exit 0; fi)
+}
package() {
- mkdir -p "$pkgdir/usr/bin"
- mv "$srcdir/lune" "$pkgdir/usr/bin"
+ cd "lune-${pkgver}"
+ install -Dm755 -t ${pkgdir}/usr/bin target/release/lune
}