summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCompey2023-07-28 14:45:11 +0530
committerCompey2023-07-28 14:45:11 +0530
commit6e9a19b737ad9220430435658f78c46c65f52aba (patch)
tree84938c144194da4cfe5db7dcbdda9fb5f1c83611
downloadaur-6e9a19b737ad9220430435658f78c46c65f52aba.tar.gz
chore(release): AUR lune-bin v0.7.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdb1a0e2406d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lune-bin
+ pkgdesc = [Precompiled Binaries] A standalone Luau script runtime
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://lune-org.github.io/docs
+ arch = x86_64
+ arch = aarch64
+ license = MPL2
+ provides = lune
+ conflicts = lune
+ source_x86_64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-x86_64.zip
+ sha256sums_x86_64 = eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c
+ source_aarch64 = https://github.com/filiptibell/lune/releases/download/v0.7.5/lune-0.7.5-linux-aarch64.zip
+ sha256sums_aarch64 = dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd
+
+pkgname = lune-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d80dccc79f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Erica Marigold <hi@devcomp.xyz>
+
+pkgname=lune-bin
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="[Precompiled Binaries] A standalone Luau script runtime"
+arch=('x86_64' 'aarch64')
+conflicts=(lune lune-git)
+url="https://lune-org.github.io/docs"
+license=('MPL2')
+provides=('lune')
+conflicts=('lune')
+source_x86_64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-x86_64.zip")
+source_aarch64=("https://github.com/filiptibell/lune/releases/download/v$pkgver/lune-$pkgver-linux-aarch64.zip")
+sha256sums_x86_64=('eaec8e6361c8f9b4e63f756cc9b83a94bbbba28b060e5338a144e499aae2881c')
+sha256sums_aarch64=('dad5292299db3359c8676c8e294cb9b30105ad1a47f9d96ee99fa34f2684f4fd')
+
+package() {
+ install -Dm755 -t "$pkgdir/usr/bin" lune
+}