summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetscoin2018-06-10 15:52:53 -0400
committermetscoin2018-06-10 15:52:53 -0400
commit530f91524235dff0198a90b1f6cc31de3db24203 (patch)
tree2fefa06075c08e9a13ba06615dc7aa0051956da0
downloadaur-530f91524235dff0198a90b1f6cc31de3db24203.tar.gz
Init lunex-qt repo
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD34
-rw-r--r--lunex-qt.desktop11
-rw-r--r--lunex-qt.install11
5 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03cf6fee6e98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lunex-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.lunexcrypto.com/
+ install = lunex-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = lunex
+ source = lunex-qt::git+https://github.com/LunexCoin/Lunex.git
+ source = lunex-qt.desktop
+ sha256sums = SKIP
+ sha256sums = 4134c65aff7b77fb52da75b9dcaf8457efac88f4bcb214a8116803e99d7c9050
+
+pkgname = lunex-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..985af6a0d9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=lunex-qt
+pkgver=1.0.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://www.lunexcrypto.com/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(lunex)
+install=lunex-qt.install
+source=("${pkgname%-git}::git+https://github.com/LunexCoin/Lunex.git"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ '4134c65aff7b77fb52da75b9dcaf8457efac88f4bcb214a8116803e99d7c9050')
+
+build() {
+ cd "$srcdir/$pkgname"
+ find . -type f -iname "*.sh" -exec chmod +x {} \;
+ ./autogen.sh
+ ./configure --with-gui=qt5
+ make
+}
+
+
+package() {
+ install -Dm644 lunex-qt.desktop "$pkgdir"/usr/share/applications/lunex.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/lunex-qt "$pkgdir"/usr/bin/lunex-qt
+ install -Dm644 share/pixmaps/dash128.png "$pkgdir"/usr/share/pixmaps/lunex128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/lunex-qt.desktop b/lunex-qt.desktop
new file mode 100644
index 000000000000..b1dde793b1dd
--- /dev/null
+++ b/lunex-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Lunex
+Comment=Lunex P2P Cryptocurrency
+Exec=/usr/bin/lunex-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/lunex128.png
+MimeType=x-scheme-handler/lunex;
+Categories=Office;
+Name[en_US]=lunex-qt.desktop
diff --git a/lunex-qt.install b/lunex-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/lunex-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}