summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:28:02 -0700
committerShadowKyogre2015-06-08 07:28:02 -0700
commitb959322e357897e87d57e2cd74e520f788acdbdd (patch)
treecf57dd71498ae936b9a8c3842407fae3535230f4
downloadaur-b959322e357897e87d57e2cd74e520f788acdbdd.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6832aa7a5351
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lunifybg-wpd-git
+ pkgdesc = Modified version of lunifybg to accommodate wallpaperd.
+ pkgver = 20130108
+ pkgrel = 1
+ url = https://gist.github.com/4438979
+ arch = any
+ license = public domain
+ makedepends = git
+ depends = imagemagick
+ depends = wallpaperd
+
+pkgname = lunifybg-wpd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5084551da8c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Sapphira Armageddos <shadowkyogre.public+aur@gmail.com>
+pkgname=lunifybg-wpd-git
+pkgver=20130108
+pkgrel=1
+pkgdesc="Modified version of lunifybg to accommodate wallpaperd."
+arch=(any)
+url="https://gist.github.com/4438979"
+license=('public domain')
+groups=()
+depends=('imagemagick' 'wallpaperd')
+makedepends=('git')
+
+_gitroot="https://gist.github.com/4438979.git"
+_gitname="lunifybg-wpd"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+package() {
+ install -Dm755 "$srcdir/$_gitname/$_gitname" "$pkgdir/usr/bin/$_gitname"
+}
+