summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stein2015-07-07 22:36:17 +0200
committerMaximilian Stein2015-07-07 22:36:17 +0200
commit5a098b559bf99e05f49e87c11e34e40c07c81d7f (patch)
tree1f55398161b76983862a313654f327f3da7a50eb
downloadaur-5a098b559bf99e05f49e87c11e34e40c07c81d7f.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d4b57d38d9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lush
+ pkgdesc = An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications.
+ pkgver = 1.2.1
+ pkgrel = 2
+ url = http://lush.sourceforge.net
+ arch = x86_64
+ arch = i686
+ license = GPL
+ optdepends = gsl
+ optdepends = lapack
+ optdepends = sdl
+ optdepends = opencv
+ optdepends = alsa-lib
+ optdepends = libxft
+ options = !libtool
+ source = http://downloads.sourceforge.net/lush/lush-1.2.1.tar.gz
+ sha256sums = 1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9
+
+pkgname = lush
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a0620c77cf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maximilian Stein <theoddbird@posteo.org>
+# Contributor: Thomas S Hatch <thatch45@gmail.com>
+# Contributor: Hannes Rist <cowider@gmail.com>
+# Contributor: ackalker <a.c.kalker@gmail.com>
+
+pkgname=lush
+pkgver=1.2.1
+pkgrel=2
+pkgdesc="An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications."
+arch=('x86_64' 'i686')
+url="http://lush.sourceforge.net"
+license=('GPL')
+optdepends=('gsl' 'lapack' 'sdl' 'opencv' 'alsa-lib' 'libxft')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9')
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+}
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir"/ install
+} \ No newline at end of file