summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stein2015-07-07 22:43:11 +0200
committerMaximilian Stein2015-07-07 22:43:11 +0200
commitb50250cc0cb635e4fafc3cebfa673e79ba3144d1 (patch)
treecf3aef19ab99bbc1608eb461ec7951e4cd44727f
downloadaur-lush2.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0dfe50748c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lush2
+ pkgdesc = An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications.
+ pkgver = 2.0.1
+ pkgrel = 3
+ url = http://lush.sourceforge.net
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ optdepends = gsl
+ optdepends = lapack
+ optdepends = sdl
+ optdepends = opencv
+ optdepends = alsa-lib
+ optdepends = libxft
+ optdepends = texlive-core
+ options = !libtool
+ source = http://downloads.sourceforge.net/lush/lush-2.0.1.tar.gz
+ sha256sums = 93441ec72b2d1afa6247f2f93d0a05796cf0d96a212442aa4b75366c8775f30a
+
+pkgname = lush2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66d96b9ae443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Maximilian Stein <theoddbird@posteo.org>
+# Contributor: derrida <deleuzians@gmail.com>
+# Contributor: gucong <gucong43216@gmail.com>
+# Contributor: ackalker <a.c.kalker@gmail.com>
+
+pkgname=lush2
+pkgver=2.0.1
+pkgrel=3
+pkgdesc="An object-oriented programming language designed for researchers, experimenters, and engineers interested in large-scale numerical and graphic applications."
+arch=('x86_64' 'i686')
+url="http://lush.sourceforge.net"
+license=('LGPL')
+optdepends=('gsl' 'lapack' 'sdl' 'opencv' 'alsa-lib' 'libxft' 'texlive-core')
+makedepends=()
+options=('!libtool')
+source=(http://downloads.sourceforge.net/lush/lush-$pkgver.tar.gz)
+sha256sums=('93441ec72b2d1afa6247f2f93d0a05796cf0d96a212442aa4b75366c8775f30a')
+build() {
+ cd "$srcdir/lush-$pkgver"
+ ./configure LIBS=-lz X_EXTRA_LIBS=-lfontconfig --prefix=/usr --with-x
+}
+package() {
+ cd "$srcdir/lush-$pkgver"
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file