summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2016-03-24 22:54:47 +1100
committerMatthew Gamble2016-03-24 22:54:47 +1100
commitc41d835f8934ef1bde64da5b5bedccb8dee14af2 (patch)
tree691f33c7b0e435d20d69ba95d7f87fba8aec0889
downloadaur-c41d835f8934ef1bde64da5b5bedccb8dee14af2.tar.gz
Initial commit of v1.0.0 of lustache-cli tool
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdc69ce7769e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lustache-cli
+ pkgdesc = A command-line interface to lustache (mustache templates for lua).
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/djmattyg007/lustache-cli
+ arch = any
+ license = UNLICENSE
+ depends = lua lua-argparse lua-luajson lustache
+ source = https://github.com/djmattyg007/lustache-cli/archive/1.0.0.tar.gz
+ sha256sums = 90f5790403b269eb37a2258d330572eab9f3036e31e858abdbb7fb02ec584d1a
+
+pkgname = lustache-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd46d0d3fa1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=lustache-cli
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A command-line interface to lustache (mustache templates for lua)."
+arch=("any")
+url="https://github.com/djmattyg007/lustache-cli"
+license=("UNLICENSE")
+depends=("lua lua-argparse lua-luajson lustache")
+source=("https://github.com/djmattyg007/lustache-cli/archive/${pkgver}.tar.gz")
+sha256sums=('90f5790403b269eb37a2258d330572eab9f3036e31e858abdbb7fb02ec584d1a')
+
+package() {
+ cd "lustache-cli-${pkgver}"
+ install -Dm755 "lustache-cli" "${pkgdir}/usr/bin/lustache-cli"
+}
+