summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:10:44 +0200
committerMaxime Gauduin2015-06-08 11:10:44 +0200
commitbda199dfb99dcd7cfebf3ece148d5ae875723db5 (patch)
tree3f8fbafea270a70cb5d10f143d2cc57fdae565da
downloadaur-bda199dfb99dcd7cfebf3ece148d5ae875723db5.tar.gz
Initial import
-rw-r--r--.SRCINFO46
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD52
-rw-r--r--lutris.install15
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5e0db999727
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = lutris
+ pkgdesc = Open Gaming Platform
+ pkgver = 0.3.6.3
+ pkgrel = 2
+ url = http://lutris.net/
+ install = lutris.install
+ arch = any
+ license = GPL3
+ makedepends = python2-setuptools
+ depends = desktop-file-utils
+ depends = glib-networking
+ depends = gvfs
+ depends = hicolor-icon-theme
+ depends = polkit
+ depends = python2-gobject
+ depends = python2-xdg
+ depends = python2-yaml
+ depends = xorg-xrandr
+ optdepends = atari800: Atari 800/800XL/130XE/5200 Emulator
+ optdepends = dolphin-emu: Nintendo Gamecube/Wii/Triforce Emulator
+ optdepends = dosbox: DOS Emulator
+ optdepends = frotz: Z-machine Interpreter
+ optdepends = fs-uae: Amiga Emulator
+ optdepends = gens-gs: Sega Genesis/CD/32X Emulator
+ optdepends = hatari: Atari ST/STE Emulator
+ optdepends = jzintv: Matel Intellivision Emulator
+ optdepends = mednafen: Multi-system Emulator
+ optdepends = mupen64plus: Nintendo 64 Emulator
+ optdepends = o2em: Magnavox Odyssey 2 Emulator
+ optdepends = openmsx: MSX Emulator
+ optdepends = osmose: Sega Master System/Gamegear Emulator
+ optdepends = pcsxr: Sony Playstation emulator
+ optdepends = residualvm: 3D Point and Click Virtual Machine
+ optdepends = scummvm: 2D Point and Click Virtual Machine
+ optdepends = sdlmame: Multiple Arcade Machine Emulator
+ optdepends = snes9x-gtk: Super Nintendo Emulator
+ optdepends = steam: Digital Gaming Platform
+ optdepends = stella: Atari 2600 Emlator
+ optdepends = vice: Commodore 64 Emulator
+ optdepends = virtualjaguar: Atari Jaguar Emulator
+ optdepends = wine: Windows Compatibility Layer
+ source = http://lutris.net/releases/lutris_0.3.6.3.tar.gz
+ sha256sums = a9061403ef8844b2c1443b1c5f15fe98af224d652d66268b47ae8e215e289058
+
+pkgname = lutris
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..a248ff86f0bb
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+arch=('any')
+pkgname=('lutris')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbe8a26c8173
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=lutris
+pkgver=0.3.6.3
+pkgrel=2
+pkgdesc='Open Gaming Platform'
+arch=('any')
+url='http://lutris.net/'
+license=('GPL3')
+depends=('desktop-file-utils' 'glib-networking' 'gvfs' 'hicolor-icon-theme'
+ 'polkit' 'python2-gobject' 'python2-xdg' 'python2-yaml' 'xorg-xrandr')
+makedepends=('python2-setuptools')
+optdepends=('atari800: Atari 800/800XL/130XE/5200 Emulator'
+ 'dolphin-emu: Nintendo Gamecube/Wii/Triforce Emulator'
+ 'dosbox: DOS Emulator'
+ 'frotz: Z-machine Interpreter'
+ 'fs-uae: Amiga Emulator'
+ 'gens-gs: Sega Genesis/CD/32X Emulator'
+ 'hatari: Atari ST/STE Emulator'
+ 'jzintv: Matel Intellivision Emulator'
+ 'mednafen: Multi-system Emulator'
+ 'mupen64plus: Nintendo 64 Emulator'
+ 'o2em: Magnavox Odyssey 2 Emulator'
+ 'openmsx: MSX Emulator'
+ 'osmose: Sega Master System/Gamegear Emulator'
+ 'pcsxr: Sony Playstation emulator'
+ 'residualvm: 3D Point and Click Virtual Machine'
+ 'scummvm: 2D Point and Click Virtual Machine'
+ 'sdlmame: Multiple Arcade Machine Emulator'
+ 'snes9x-gtk: Super Nintendo Emulator'
+ 'steam: Digital Gaming Platform'
+ 'stella: Atari 2600 Emlator'
+ 'vice: Commodore 64 Emulator'
+ 'virtualjaguar: Atari Jaguar Emulator'
+ 'wine: Windows Compatibility Layer')
+install='lutris.install'
+source=("http://lutris.net/releases/lutris_${pkgver}.tar.gz")
+sha256sums=('a9061403ef8844b2c1443b1c5f15fe98af224d652d66268b47ae8e215e289058')
+
+prepare() {
+ cd lutris
+
+ sed -i 's|^#!.*python$|#!/usr/bin/python2|' $(grep -rl '^#!.*python')
+}
+
+package() {
+ cd lutris
+
+ python2 setup.py install --root="${pkgdir}" --optimize='1'
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/lutris.install b/lutris.install
new file mode 100644
index 000000000000..c4361eea225a
--- /dev/null
+++ b/lutris.install
@@ -0,0 +1,15 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: