summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Fuentes2020-10-13 13:11:15 -0400
committerVictor Fuentes2020-10-13 13:11:15 -0400
commit940e9ef5a33850bf145a7f5cbe1ddffe852a5535 (patch)
treecaffa2d99c8516ee764037cc7476b2f2376070b4
parentbd5c86b9b2a2fee35f88124576dae754f9661d98 (diff)
downloadaur-940e9ef5a33850bf145a7f5cbe1ddffe852a5535.tar.gz
Remove patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--test-fix.patch22
3 files changed, 5 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86bfa6c09a52..6de02bebd4f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.7.1.r274.g88e4ffa6
+ pkgver = 0.5.7.1.r278.g59c18e1c
pkgrel = 1
url = https://lutris.net/
arch = any
@@ -44,9 +44,7 @@ pkgbase = lutris-git
provides = lutris
conflicts = lutris
source = git+https://github.com/lutris/lutris.git
- source = test-fix.patch
sha256sums = SKIP
- sha256sums = 2e627ec7ddcfcc4c5180cb837163966705288c18cc75447872df6c669c9c7516
pkgname = lutris-git
diff --git a/PKGBUILD b/PKGBUILD
index 31002a033541..ad9bc203c7f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=lutris-git
_pkgname=lutris
-pkgver=0.5.7.1.r274.g88e4ffa6
+pkgver=0.5.7.1.r278.g59c18e1c
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -29,10 +29,8 @@ optdepends=(
'python-pypresence: Discord RPC and Rich Presence')
provides=('lutris')
conflicts=('lutris')
-source=('git+https://github.com/lutris/lutris.git'
- 'test-fix.patch')
-sha256sums=('SKIP'
- '2e627ec7ddcfcc4c5180cb837163966705288c18cc75447872df6c669c9c7516')
+source=('git+https://github.com/lutris/lutris.git')
+sha256sums=('SKIP')
pkgver() {
cd ${_pkgname}
@@ -48,7 +46,7 @@ build() {
check() {
cd ${_pkgname}
- patch --strip=1 --input="${srcdir}/test-fix.patch"
+
xvfb-run nosetests --cover-erase --with-xunit --xunit-file=nosetests.xml --with-coverage --cover-package=lutris --cover-xml-file=coverage.xml
}
diff --git a/test-fix.patch b/test-fix.patch
deleted file mode 100644
index e37596552808..000000000000
--- a/test-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 11aed2b2c07331903936caa5f70d20a150069996 Mon Sep 17 00:00:00 2001
-From: harre <mail@hartmark.se>
-Date: Sun, 11 Oct 2020 00:25:01 +0200
-Subject: [PATCH] Fix failing test #3192
-
----
- tests/test_dialogs.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_dialogs.py b/tests/test_dialogs.py
-index a7cefa316..8dc89f087 100644
---- a/tests/test_dialogs.py
-+++ b/tests/test_dialogs.py
-@@ -102,7 +102,7 @@ def test_can_add_game(self):
- self.assertTrue(pga_game)
- game = Game(pga_game['id'])
- self.assertEqual(game.name, 'Test game')
-- game.remove(from_library=True)
-+ game.remove()
-
-
- class TestSort(TestCase):