summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-21 22:11:41 +0200
committerGordian Edenhofer2016-04-21 22:11:41 +0200
commit219d08ef2ed55bbd8bea0a7d3bb9594becfc7ea6 (patch)
treec5b8abbddc6714b537363cb686c5e84384e753f1
downloadaur-219d08ef2ed55bbd8bea0a7d3bb9594becfc7ea6.tar.gz
addpkg: luv-icon-theme-git 0.1.r3.g3de1abd-1
The package flattr-icon-theme-git was renamed upstream on 2016-04-21.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--luv-icon-theme-git.install12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..168c94f294cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = luv-icon-theme-git
+ pkgdesc = The spiritual successor to Flattr, a flat but complex icon theme for freedesktop environments.
+ pkgver = 0.1.r3.g3de1abd
+ pkgrel = 1
+ url = https://github.com/NitruxSA/luv-icon-theme
+ install = luv-icon-theme-git.install
+ arch = any
+ license = custom:CC BY-SA 4.0
+ makedepends = git
+ depends = librsvg
+ provides = flattr-icon-theme
+ provides = luv-icon-theme
+ conflicts = flattr-icon-theme
+ conflicts = luv-icon-theme
+ source = luv-icon-theme-git::git+https://github.com/NitruxSA/luv-icon-theme.git
+ md5sums = SKIP
+
+pkgname = luv-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32eb1ab699db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Submitter: Steffen L. Norgren (incongruous) <steffen[at]norgren[dot]ca>
+
+pkgname=luv-icon-theme-git
+pkgver=0.1.r3.g3de1abd
+pkgrel=1
+pkgdesc="The spiritual successor to Flattr, a flat but complex icon theme for freedesktop environments."
+arch=('any')
+url="https://github.com/NitruxSA/luv-icon-theme"
+license=('custom:CC BY-SA 4.0')
+depends=('librsvg')
+makedepends=('git')
+provides=('flattr-icon-theme' 'luv-icon-theme')
+conflicts=('flattr-icon-theme' 'luv-icon-theme')
+install="${pkgname}.install"
+source=("${pkgname}"::'git+https://github.com/NitruxSA/luv-icon-theme.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^luv.v//;s/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/icons/Luv"
+ install -dm755 "${pkgdir}/usr/share/icons/Luv Dark"
+ cp -dpr --no-preserve=ownership ./Lüv/* "${pkgdir}/usr/share/icons/Luv"
+ cp -dpr --no-preserve=ownership ./Lüv\ Dark/* "${pkgdir}/usr/share/icons/Luv Dark"
+
+ install -Dm644 "./Lüv/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "./CREDITS" "${pkgdir}/usr/share/licenses/${pkgname}/CREDITS"
+ rm "${pkgdir}"/usr/share/icons/{Luv,Luv\ Dark}/LICENSE
+}
diff --git a/luv-icon-theme-git.install b/luv-icon-theme-git.install
new file mode 100644
index 000000000000..a4387ad4c277
--- /dev/null
+++ b/luv-icon-theme-git.install
@@ -0,0 +1,12 @@
+_update() {
+ echo -e "\e[34;1m==>\e[39;1m Updating icon cache...\e[0m"
+ gtk-update-icon-cache -q /usr/share/icons/Flattr
+}
+
+post_install() {
+ _update
+}
+
+post_upgrade() {
+ _update
+}