summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoniEx22016-07-13 18:06:19 -0300
committerSoniEx22016-07-13 18:06:19 -0300
commit557c6b9d0f9c0ee58ec5725316d887b2f1252f97 (patch)
tree1a6f59191e3f11480ed18d29a4828bf1b2856959
downloadaur-557c6b9d0f9c0ee58ec5725316d887b2f1252f97.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5479e636313
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = luvit
+ pkgdesc = node.js style APIs for luvi as either a luvi app or library.
+ pkgver = 2.11.4
+ pkgrel = 1
+ url = https://github.com/luvit/luvit
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = lit
+ depends = gcc-libs
+ noextract = luvit.zip
+ options = !strip
+ source = luvit.zip::https://lit.luvit.io/packages/luvit/luvit/v2.11.4.zip
+ sha256sums = d564330480ca755a15b158a36dfa2b87ba8b93ec9f6206f99da1ce4a789fb431
+
+pkgname = luvit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1b246b4f1a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: SoniEx2 <endermoneymod at gmail dot com>
+pkgname=luvit
+pkgver=2.11.4
+pkgrel=1
+pkgdesc="node.js style APIs for luvi as either a luvi app or library."
+arch=(i686 x86_64)
+url="https://github.com/luvit/luvit"
+license=('Apache')
+groups=()
+depends=('gcc-libs')
+makedepends=('lit')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!strip)
+install=
+changelog=
+source=("luvit.zip::https://lit.luvit.io/packages/luvit/luvit/v$pkgver.zip")
+noextract=("luvit.zip")
+sha256sums=('d564330480ca755a15b158a36dfa2b87ba8b93ec9f6206f99da1ce4a789fb431')
+
+build() {
+ cd "$srcdir"
+
+ lit make luvit.zip
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 luvit "$pkgdir/usr/bin/luvit"
+}