summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormanjaro2019-05-25 10:14:01 +0200
committerbartus2019-05-25 21:48:48 +0200
commit0328fbb5bc185a154192e25dea30ba717d0bf3a0 (patch)
treef65e5490c23ab9e444b6f8d9f15d1928b88bde81
parentf27df41da68ae149c5ba0eddf72182a9d1e50fbc (diff)
downloadaur-0328fbb5bc185a154192e25dea30ba717d0bf3a0.tar.gz
Add Travis Ci build and deploy.
-rw-r--r--.travis.yml36
-rw-r--r--.travis_deploy.sh8
2 files changed, 44 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..d812bc9c0234
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,36 @@
+sudo: required
+
+branches:
+ only:
+ - master
+
+cache:
+ directories:
+ - src
+# - AUR-repo
+
+services:
+- docker
+
+arch:
+ repos:
+# - papyros=http://dash.papyros.io/repos/$repo/$arch
+ - bartus=https://github.com/bartoszek/AUR-repo/raw/master
+ packages:
+ # arch/aur packages
+# - python
+# - perl
+ script:
+# - "sudo pacman -Sy"
+ - "makepkg -se --noconfirm"
+
+script:
+- "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+- "ls $(pwd)"
+
+deploy:
+ provider: script
+ script: bash .travis_deploy.sh
+ on:
+ branch: master
+ skip_cleanup: true
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..80cd4b90ceeb
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname*$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname*$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push