summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-10-06 14:42:56 +0200
committerbartus2019-10-06 14:42:56 +0200
commit12204ec30fbfa5b0f6a77ca1432dbab31936a9fc (patch)
tree15c876c735dcace390c697cf9beac0c1600a53ba
parent587524ca89f3c286ec0aaefeac75b886a5e07ce7 (diff)
downloadaur-12204ec30fbfa5b0f6a77ca1432dbab31936a9fc.tar.gz
Add scripted _pyver.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82ec227d41a1..a2a1bc6c0e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxcorerender
pkgdesc = LuxCoreRender is a physically correct, unbiased rendering engine.
pkgver = 2.2
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://www.luxcorerender.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1951a1dec461..a360d305529d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=luxcorerender
pkgver=2.2
#_rel="rc1"
[ -n "${_rel}" ] && _pkgver=${pkgver}${_rel} && pkgver+=".${_rel}" || _pkgver=${pkgver}
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
arch=('x86_64')
@@ -34,9 +34,10 @@ prepare() {
}
build() {
+ _pyver=$(python -c "from sys import version_info; print(\"%d%d\" % (version_info[0],version_info[1]))")
cd ${srcdir}/LuxCore-${pkgname}_v${_pkgver}
mkdir -p build && cd build
- cmake -DPYTHON_V=3 ..
+ cmake -DPYTHON_V=${_pyver} ..
make
}