summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-10-04 14:37:18 +0200
committerbartus2018-10-04 14:37:18 +0200
commit1b60a81275fd992a0dc527a7de7ec2fe2f1207fe (patch)
treed54019c0595e1dfa5e6aa8622631c3fc5a8fa308
parent5dfb13f1f794e127b4f770317baa67fd13f19f94 (diff)
downloadaur-1b60a81275fd992a0dc527a7de7ec2fe2f1207fe.tar.gz
pack alpha4 ver
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--python.patch9
3 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14a59dc05f9d..a0e364bb24f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxcorerender
pkgdesc = LuxCoreRender is a physically correct, unbiased rendering engine.
pkgver = 2.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.luxcorerender.org/
arch = x86_64
license = Apache
@@ -22,11 +22,11 @@ pkgbase = luxcorerender
provides = luxrays
conflicts = luxrays-hg
options = !buildflags
- source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.1alpha1.tar.gz
+ source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.1alpha4.tar.gz
source = python.patch
source = glfw.patch
- md5sums = 43ec2a57c44681c2ebc308a563d15e60
- md5sums = a1b1594fbb809597759d0573702c06b2
+ md5sums = 7255c3027aab84ef7bed084af1ba850b
+ md5sums = 21b963e5f66d2c8c6a50bebcf9f0fe07
md5sums = 624f2be4cb431f6a4cfcc968d6263ac2
pkgname = luxcorerender
diff --git a/PKGBUILD b/PKGBUILD
index 5ab3747a4c8a..6a7857785e2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=luxcorerender
pkgver=2.1
-pkgrel=1
+_alpha=4
+pkgrel=2
pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
@@ -13,16 +14,16 @@ makedepends=(git doxygen cmake python-pyside-tools opencl-headers)
conflicts=(luxrays-hg)
provides=(luxrays)
options=('!buildflags')
-source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}alpha1.tar.gz"
+source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}alpha${_alpha}.tar.gz"
"python.patch"
"glfw.patch"
)
-md5sums=('43ec2a57c44681c2ebc308a563d15e60'
- 'a1b1594fbb809597759d0573702c06b2'
+md5sums=('7255c3027aab84ef7bed084af1ba850b'
+ '21b963e5f66d2c8c6a50bebcf9f0fe07'
'624f2be4cb431f6a4cfcc968d6263ac2')
prepare() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
msg "python.patch"
patch -Np1 < ../python.patch
msg "glfw.patch"
@@ -30,14 +31,14 @@ prepare() {
}
build() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
mkdir -p build && cd build
- cmake ..
+ cmake -DPYTHON_V=3 ..
make
}
package() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha1/build
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}/build
install -d -m755 ${pkgdir}/usr/{bin,include,lib}
install -m755 bin/* ${pkgdir}/usr/bin
diff --git a/python.patch b/python.patch
index 4a4bd4ef88f5..7d4c4d4f0ab8 100644
--- a/python.patch
+++ b/python.patch
@@ -10,15 +10,6 @@ diff -Naur orig/LuxCore-luxcorerender_v2.0/cmake/Dependencies.cmake LuxCore-luxc
endif()
find_program(PYSIDE_UIC NAME pyside-uic
-@@ -63,7 +63,7 @@
-
- set(Boost_ADDITIONAL_VERSIONS "1.47.0" "1.46.1" "1.46" "1.46.0" "1.45" "1.45.0" "1.44" "1.44.0")
-
--set(LUXRAYS_BOOST_COMPONENTS thread program_options filesystem serialization iostreams regex system python chrono serialization)
-+set(LUXRAYS_BOOST_COMPONENTS thread program_options filesystem serialization iostreams regex system python3 chrono serialization)
- find_package(Boost ${Boost_MINIMUM_VERSION} COMPONENTS ${LUXRAYS_BOOST_COMPONENTS})
- if (NOT Boost_FOUND)
- # Try again with the other type of libs
diff -Naur orig/LuxCore-luxcorerender_v2.0/CMakeLists.txt LuxCore-luxcorerender_v2.0/CMakeLists.txt
--- orig/LuxCore-luxcorerender_v2.0/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
+++ LuxCore-luxcorerender_v2.0/CMakeLists.txt 2018-05-11 16:30:33.742293724 +0200