summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-08-14 14:49:58 +0000
committerbartus2020-08-14 14:49:58 +0000
commit797bab5ec3d420211762288210a2dab94360952a (patch)
treeec742949a40ea7440249e8f0fe9853dc9232fc77
parentcdf30713a3d1bb5c80a075aa70ffa27baf53be62 (diff)
downloadaur-797bab5ec3d420211762288210a2dab94360952a.tar.gz
Pop version 2.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--boost016900_serialization.patch41
-rw-r--r--python.patch45
4 files changed, 38 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a6fb5e7de41..1c09ab1843ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = luxcorerender
pkgdesc = Physically correct, unbiased rendering engine.
- pkgver = 2.3
+ pkgver = 2.4
pkgrel = 1
epoch = 2
url = https://www.luxcorerender.org/
arch = x86_64
license = Apache
makedepends = opencl-headers
+ makedepends = cuda
makedepends = boost
makedepends = git
makedepends = doxygen
@@ -24,14 +25,12 @@ pkgbase = luxcorerender
optdepends = opencl-driver: for gpu acceleration
optdepends = pyside2: for pyluxcoretools gui
provides = luxrays
- source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.3.tar.gz
+ source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.4.tar.gz
source = python.patch
source = glfw.patch
- source = boost016900_serialization.patch
- sha256sums = d0afda77bd2a89ac050255495d8b0939096d259a92cf99fa5a92a51256a3d8a4
- sha256sums = a00ee865eee4d9edf685bd4010aea4c3ae96ba5d22c2e17cda313b4d3468a806
+ sha256sums = b80486f2340a130257a50686337be04802c32df8a4e2dfe2ac6ccc1e2b6e7482
+ sha256sums = f639fb7e31056b6c7214e303c90fe06665572ffafc11e545f7c05128a8d85dc4
sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
- sha256sums = 495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760
pkgname = luxcorerender
diff --git a/PKGBUILD b/PKGBUILD
index 4bd8d8465d83..cb8f55ec9143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,28 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
# Configuration
-((DISABLE_OPENCL)) || {
+# shellcheck disable=SC2015
+((DISABLE_OPENCL)) && {
+ CMAKE_FLAGS+=("-DLUXRAYS_DISABLE_OPENCL=ON")
+} || {
depends+=(opencl-icd-loader)
makedepends+=(opencl-headers)
optdepends+=("opencl-driver: for gpu acceleration")
- CMAKE_FLAGS+=("-DLUXRAYS_DISABLE_OPENCL=ON")
+}
+# shellcheck disable=SC2015
+((DISABLE_CUDA||DISABLE_OPENCL)) && {
+ CMAKE_FLAGS+=("-DLUXRAYS_DISABLE_CUDA=ON")
+} || {
+ makedepends+=(cuda)
}
pkgname=luxcorerender
-pkgver=2.3
+pkgver=2.4
_name=LuxCore-${pkgname}_v${pkgver}
#_rel="rc1"
[ -n "${_rel}" ] && _pkgver=${pkgver}${_rel} && pkgver+=".${_rel}" || _pkgver=${pkgver}
-pkgrel=1
epoch=2
+pkgrel=1
pkgdesc="Physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
@@ -27,12 +35,10 @@ provides=(luxrays)
source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${_pkgver}.tar.gz"
"python.patch"
"glfw.patch"
- "boost016900_serialization.patch"
)
-sha256sums=('d0afda77bd2a89ac050255495d8b0939096d259a92cf99fa5a92a51256a3d8a4'
- 'a00ee865eee4d9edf685bd4010aea4c3ae96ba5d22c2e17cda313b4d3468a806'
- '4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
- '495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760')
+sha256sums=('b80486f2340a130257a50686337be04802c32df8a4e2dfe2ac6ccc1e2b6e7482'
+ 'f639fb7e31056b6c7214e303c90fe06665572ffafc11e545f7c05128a8d85dc4'
+ '4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1')
prepare() {
for patch in "${srcdir}"/*.patch; do
diff --git a/boost016900_serialization.patch b/boost016900_serialization.patch
deleted file mode 100644
index 900a2573403d..000000000000
--- a/boost016900_serialization.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-commit 9478fb60fd00a30c048841d0e3764673e77a47b5
-Author: bartus <bartus@manjaro>
-Date: Sat Mar 30 13:17:45 2019 +0000
-
- drop eos portable archiver
-
-diff --git a/include/luxrays/utils/serializationutils.h b/include/luxrays/utils/serializationutils.h
-index d2cec5ed6..e35812765 100644
---- a/include/luxrays/utils/serializationutils.h
-+++ b/include/luxrays/utils/serializationutils.h
-@@ -42,19 +42,22 @@
- #include <boost/serialization/set.hpp>
- #include <boost/serialization/vector.hpp>
-
--//#include <boost/archive/binary_iarchive.hpp>
--//#include <boost/archive/binary_oarchive.hpp>
--#include "eos/portable_oarchive.hpp"
--#include "eos/portable_iarchive.hpp"
-+#include <boost/archive/binary_iarchive.hpp>
-+#include <boost/archive/binary_oarchive.hpp>
-+#include <boost/archive/polymorphic_oarchive.hpp>
-+#include <boost/archive/polymorphic_iarchive.hpp>
-+#include <boost/lexical_cast.hpp>
-+//#include "eos/portable_oarchive.hpp"
-+//#include "eos/portable_iarchive.hpp"
-
- #include "luxrays/luxrays.h"
-
- namespace luxrays {
-
--//typedef boost::archive::binary_oarchive LuxOutputArchive;
--//typedef boost::archive::binary_iarchive LuxInputArchive;
--typedef eos::portable_oarchive LuxOutputArchive;
--typedef eos::portable_iarchive LuxInputArchive;
-+typedef boost::archive::binary_oarchive LuxOutputArchive;
-+typedef boost::archive::binary_iarchive LuxInputArchive;
-+//typedef eos::portable_oarchive LuxOutputArchive;
-+//typedef eos::portable_iarchive LuxInputArchive;
-
- class SerializationOutputFile {
- public:
diff --git a/python.patch b/python.patch
index 205a2d12ee35..ee6a94da8aa7 100644
--- a/python.patch
+++ b/python.patch
@@ -1,5 +1,5 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a4a073f2e..4025bc894 100644
+index 7dda21b7d..fe41ec5d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,10 @@ MESSAGE(STATUS "CMake version " ${CMAKE_VERSION} " detected")
@@ -14,58 +14,49 @@ index a4a073f2e..4025bc894 100644
SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
-index dc3f5d8cf..a8b429814 100644
+index be614b8e8..94918929e 100644
--- a/samples/luxcoreconsole/CMakeLists.txt
+++ b/samples/luxcoreconsole/CMakeLists.txt
@@ -28,4 +28,4 @@ set(LUXCORECONSOLE_SRCS
add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
--TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
\ No newline at end of file
-+TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
-index c140dc23b..c8cba9880 100644
+index 194104caf..241dbd5f2 100644
--- a/samples/luxcoredemo/CMakeLists.txt
+++ b/samples/luxcoredemo/CMakeLists.txt
@@ -29,4 +29,4 @@ set(LUXCORELIBDEMO_SRCS
add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
--TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
-index 90c1967cd..aa024f650 100644
+index 3acb27bfa..b52d3ec81 100644
--- a/samples/luxcorescenedemo/CMakeLists.txt
+++ b/samples/luxcorescenedemo/CMakeLists.txt
@@ -29,4 +29,4 @@ set(LUXCORESCENEDEMO_SRCS
add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
--TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
-index 33b50b3d0..ba1982a42 100644
+index c8b23001b..607f92b6a 100644
--- a/samples/luxcoreui/CMakeLists.txt
+++ b/samples/luxcoreui/CMakeLists.txt
-@@ -88,4 +91,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
+@@ -89,4 +92,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
+ ${LUXCORE_LIBRARY}
${OPENGL_LIBRARIES}
${GTK3_LIBRARIES}
- ${Boost_LIBRARIES}
-+ ${PYTHON_LIBRARIES}
- ${OPENCL_LIBRARIES})
-diff --git a/tests/benchsimple/CMakeLists.txt b/tests/benchsimple/CMakeLists.txt
-index 3ac004b2b..b2abe340c 100644
---- a/tests/benchsimple/CMakeLists.txt
-+++ b/tests/benchsimple/CMakeLists.txt
-@@ -22,4 +22,4 @@ link_directories (${LuxRays_LIB_DIR})
- add_executable(benchsimple benchsimple.cpp)
- add_definitions(${VISIBILITY_FLAGS})
- remove_definitions("-DLUXCORE_DLL")
--target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${TBB_LIBRARY} )
-+target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} )
+- ${Boost_LIBRARIES})
++ ${Boost_LIBRARIES}
++ ${PYTHON_LIBRARIES})
diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
-index c8d9c4aa9..1dc6b7c63 100644
+index edd6e6762..1875ee5cf 100644
--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
+++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
@@ -30,4 +30,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
@@ -73,5 +64,5 @@ index c8d9c4aa9..1dc6b7c63 100644
add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-\ Brak znaku nowej linii na końcu pliku
+\ No newline at end of file
+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})