summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-03-30 15:08:45 +0100
committerbartus2019-03-30 15:08:45 +0100
commitb1dcaccf190903193e79ad39ed139185203fff00 (patch)
tree838177fa88821334787d5b16c30a39ba0df54295
parent42bd08b9966b6305d13a185a8178a365ceb9bc10 (diff)
downloadaur-b1dcaccf190903193e79ad39ed139185203fff00.tar.gz
drop eos, pop version, refactor patches
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--boost016900_serialization.patch41
-rw-r--r--glfw.patch7
-rw-r--r--python.patch85
5 files changed, 109 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1c694bcbdf2..9e8d11e29b37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxcorerender
pkgdesc = LuxCoreRender is a physically correct, unbiased rendering engine.
- pkgver = 2.1
- pkgrel = 5
+ pkgver = 2.2.alpha1
+ pkgrel = 1
epoch = 1
url = https://www.luxcorerender.org/
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = luxcorerender
makedepends = cmake
makedepends = python-pyside-tools
makedepends = opencl-headers
+ depends = oidn
depends = openimageio
depends = boost
depends = blosc
@@ -22,13 +23,14 @@ pkgbase = luxcorerender
optdepends = python-pyside: for pyluxcoretools gui
provides = luxrays
conflicts = luxrays-hg
- options = !buildflags
- source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.1.tar.gz
+ source = https://github.com/LuxCoreRender/LuxCore/archive/luxcorerender_v2.2alpha1.tar.gz
source = python.patch
source = glfw.patch
- md5sums = 04f51b65e99a9979befae3298206cdac
- md5sums = 21b963e5f66d2c8c6a50bebcf9f0fe07
- md5sums = 624f2be4cb431f6a4cfcc968d6263ac2
+ source = boost016900_serialization.patch
+ md5sums = 028c799d069db672056deb81802a282d
+ md5sums = 8e2fd7337fe6afaf5b2801426837f600
+ md5sums = e2a20172b7b7ac92a7002b6218afe327
+ md5sums = 52f097678654151e2b5427d271a7e69d
pkgname = luxcorerender
diff --git a/PKGBUILD b/PKGBUILD
index e3795a144e6b..b7b98fd92fd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=luxcorerender
-pkgver=2.1
-#_rel="beta3"
-[ -n "${_rel}" ] && _pkgver+=${_rel} && pkgver+=".${_rel}" || _pkgver=${pkgver}
-pkgrel=5
+pkgver=2.2
+_rel="alpha1"
+[ -n "${_rel}" ] && _pkgver=${pkgver}${_rel} && pkgver+=".${_rel}" || _pkgver=${pkgver}
+pkgrel=1
epoch=1
pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
license=('Apache')
-depends=(openimageio boost blosc embree glfw-x11 gtk3 opencl-icd-loader)
+depends=(oidn openimageio boost blosc embree glfw-x11 gtk3 opencl-icd-loader)
optdepends=("opencl-driver: for gpu acceleration"
"python-pyside: for pyluxcoretools gui")
makedepends=(git doxygen cmake python-pyside-tools opencl-headers)
conflicts=(luxrays-hg)
provides=(luxrays)
-options=('!buildflags')
source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${_pkgver}.tar.gz"
"python.patch"
"glfw.patch"
+ "boost016900_serialization.patch"
)
-md5sums=('04f51b65e99a9979befae3298206cdac'
- '21b963e5f66d2c8c6a50bebcf9f0fe07'
- '624f2be4cb431f6a4cfcc968d6263ac2')
+md5sums=('028c799d069db672056deb81802a282d'
+ '8e2fd7337fe6afaf5b2801426837f600'
+ 'e2a20172b7b7ac92a7002b6218afe327'
+ '52f097678654151e2b5427d271a7e69d')
prepare() {
cd ${srcdir}/LuxCore-${pkgname}_v${_pkgver}
- msg "python.patch"
- patch -Np1 < ../python.patch
- msg "glfw.patch"
- patch -Np1 < ../glfw.patch
+ for patch in ${srcdir}/*.patch; do
+ msg2 "apply $patch..."
+ patch -Np1 -i $patch
+ done
}
build() {
diff --git a/boost016900_serialization.patch b/boost016900_serialization.patch
new file mode 100644
index 000000000000..900a2573403d
--- /dev/null
+++ b/boost016900_serialization.patch
@@ -0,0 +1,41 @@
+commit 9478fb60fd00a30c048841d0e3764673e77a47b5
+Author: bartus <bartus@manjaro>
+Date: Sat Mar 30 13:17:45 2019 +0000
+
+ drop eos portable archiver
+
+diff --git a/include/luxrays/utils/serializationutils.h b/include/luxrays/utils/serializationutils.h
+index d2cec5ed6..e35812765 100644
+--- a/include/luxrays/utils/serializationutils.h
++++ b/include/luxrays/utils/serializationutils.h
+@@ -42,19 +42,22 @@
+ #include <boost/serialization/set.hpp>
+ #include <boost/serialization/vector.hpp>
+
+-//#include <boost/archive/binary_iarchive.hpp>
+-//#include <boost/archive/binary_oarchive.hpp>
+-#include "eos/portable_oarchive.hpp"
+-#include "eos/portable_iarchive.hpp"
++#include <boost/archive/binary_iarchive.hpp>
++#include <boost/archive/binary_oarchive.hpp>
++#include <boost/archive/polymorphic_oarchive.hpp>
++#include <boost/archive/polymorphic_iarchive.hpp>
++#include <boost/lexical_cast.hpp>
++//#include "eos/portable_oarchive.hpp"
++//#include "eos/portable_iarchive.hpp"
+
+ #include "luxrays/luxrays.h"
+
+ namespace luxrays {
+
+-//typedef boost::archive::binary_oarchive LuxOutputArchive;
+-//typedef boost::archive::binary_iarchive LuxInputArchive;
+-typedef eos::portable_oarchive LuxOutputArchive;
+-typedef eos::portable_iarchive LuxInputArchive;
++typedef boost::archive::binary_oarchive LuxOutputArchive;
++typedef boost::archive::binary_iarchive LuxInputArchive;
++//typedef eos::portable_oarchive LuxOutputArchive;
++//typedef eos::portable_iarchive LuxInputArchive;
+
+ class SerializationOutputFile {
+ public:
diff --git a/glfw.patch b/glfw.patch
index 5844c5414e49..29c1e0fef7af 100644
--- a/glfw.patch
+++ b/glfw.patch
@@ -1,5 +1,7 @@
---- LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ CMakeLists.txt 2018-05-13 12:50:20.599796898 +0200
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index 33b50b3d0..ba1982a42 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
@@ -22,7 +22,10 @@
#
#############################################################################
@@ -11,3 +13,4 @@
+ENDIF()
include_directories(deps/glfw-3.1.1/include)
include_directories(deps/nfd/include)
+
diff --git a/python.patch b/python.patch
index 7d4c4d4f0ab8..51bede663a3f 100644
--- a/python.patch
+++ b/python.patch
@@ -1,19 +1,8 @@
-diff -Naur orig/LuxCore-luxcorerender_v2.0/cmake/Dependencies.cmake LuxCore-luxcorerender_v2.0/cmake/Dependencies.cmake
---- orig/LuxCore-luxcorerender_v2.0/cmake/Dependencies.cmake 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/cmake/Dependencies.cmake 2018-05-11 16:22:01.774281916 +0200
-@@ -43,7 +43,7 @@
- find_package(PNG REQUIRED)
- include_directories(BEFORE SYSTEM ${PNG_PNG_INCLUDE_DIR})
- # Find Python Libraries
-- find_package(PythonLibs 3.4)
-+ find_package(PythonLibs)
- endif()
-
- find_program(PYSIDE_UIC NAME pyside-uic
-diff -Naur orig/LuxCore-luxcorerender_v2.0/CMakeLists.txt LuxCore-luxcorerender_v2.0/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/CMakeLists.txt 2018-05-11 16:30:33.742293724 +0200
-@@ -28,6 +28,10 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a4a073f2e..4025bc894 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,6 +28,10 @@ MESSAGE(STATUS "CMake version " ${CMAKE_VERSION} " detected")
cmake_minimum_required(VERSION 3.5.1)
cmake_policy(VERSION 3.0)
@@ -24,58 +13,64 @@ diff -Naur orig/LuxCore-luxcorerender_v2.0/CMakeLists.txt LuxCore-luxcorerender_
# Remove the following when the version check is at least 2.8.4
SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
-diff -Naur orig/LuxCore-luxcorerender_v2.0/samples/luxcoreconsole/CMakeLists.txt LuxCore-luxcorerender_v2.0/samples/luxcoreconsole/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/samples/luxcoreconsole/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/samples/luxcoreconsole/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -28,4 +28,4 @@
+diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
+index dc3f5d8cf..a8b429814 100644
+--- a/samples/luxcoreconsole/CMakeLists.txt
++++ b/samples/luxcoreconsole/CMakeLists.txt
+@@ -28,4 +28,4 @@ set(LUXCORECONSOLE_SRCS
add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
-TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-\ Brak znaku nowej linii na końcu pliku
+\ No newline at end of file
+TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff -Naur orig/LuxCore-luxcorerender_v2.0/samples/luxcoredemo/CMakeLists.txt LuxCore-luxcorerender_v2.0/samples/luxcoredemo/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/samples/luxcoredemo/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/samples/luxcoredemo/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -29,4 +29,4 @@
+diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
+index c140dc23b..c8cba9880 100644
+--- a/samples/luxcoredemo/CMakeLists.txt
++++ b/samples/luxcoredemo/CMakeLists.txt
+@@ -29,4 +29,4 @@ set(LUXCORELIBDEMO_SRCS
add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
-TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
+TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff -Naur orig/LuxCore-luxcorerender_v2.0/samples/luxcorescenedemo/CMakeLists.txt LuxCore-luxcorerender_v2.0/samples/luxcorescenedemo/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/samples/luxcorescenedemo/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/samples/luxcorescenedemo/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -29,4 +29,4 @@
+diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
+index 90c1967cd..aa024f650 100644
+--- a/samples/luxcorescenedemo/CMakeLists.txt
++++ b/samples/luxcorescenedemo/CMakeLists.txt
+@@ -29,4 +29,4 @@ set(LUXCORESCENEDEMO_SRCS
add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
+TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff -Naur orig/LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/samples/luxcoreui/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -88,4 +88,5 @@
+diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
+index 33b50b3d0..ba1982a42 100644
+--- a/samples/luxcoreui/CMakeLists.txt
++++ b/samples/luxcoreui/CMakeLists.txt
+@@ -88,4 +91,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
${OPENGL_LIBRARIES}
${GTK3_LIBRARIES}
${Boost_LIBRARIES}
+ ${PYTHON_LIBRARIES}
${OPENCL_LIBRARIES})
-diff -Naur orig/LuxCore-luxcorerender_v2.0/tests/benchsimple/CMakeLists.txt LuxCore-luxcorerender_v2.0/tests/benchsimple/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/tests/benchsimple/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/tests/benchsimple/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -22,4 +22,4 @@
+diff --git a/tests/benchsimple/CMakeLists.txt b/tests/benchsimple/CMakeLists.txt
+index 3ac004b2b..b2abe340c 100644
+--- a/tests/benchsimple/CMakeLists.txt
++++ b/tests/benchsimple/CMakeLists.txt
+@@ -22,4 +22,4 @@ link_directories (${LuxRays_LIB_DIR})
add_executable(benchsimple benchsimple.cpp)
add_definitions(${VISIBILITY_FLAGS})
remove_definitions("-DLUXCORE_DLL")
-target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${TBB_LIBRARY} )
+target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} )
-diff -Naur orig/LuxCore-luxcorerender_v2.0/tests/luxcoreimplserializationdemo/CMakeLists.txt LuxCore-luxcorerender_v2.0/tests/luxcoreimplserializationdemo/CMakeLists.txt
---- orig/LuxCore-luxcorerender_v2.0/tests/luxcoreimplserializationdemo/CMakeLists.txt 2018-05-06 11:04:25.000000000 +0200
-+++ LuxCore-luxcorerender_v2.0/tests/luxcoreimplserializationdemo/CMakeLists.txt 2018-05-11 16:22:01.774281916 +0200
-@@ -30,4 +30,4 @@
-
+diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+index c8d9c4aa9..1dc6b7c63 100644
+--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
++++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
+@@ -30,4 +30,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
+
add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+
+-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})