summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreplit2019-12-28 13:02:09 +0000
committerreplit2019-12-28 13:42:47 +0000
commit39e6d33263b45dd8855584c71aa943bd23191d55 (patch)
treedda6189358196a1c8dc13e3520e67b6937873006
parenta299663c4854db67163c2f91b2e05f5b6d7e378c (diff)
downloadaur-39e6d33263b45dd8855584c71aa943bd23191d55.tar.gz
Update python patch
Fix #1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--python.patch7
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cee11e4f9b79..6448c7ad522f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,7 +32,7 @@ pkgbase = luxcorerender-git
source = glfw.patch
source = boost016900_serialization.patch
sha256sums = SKIP
- sha256sums = 92bf04a12ce6a1f559eb3b129e324e0349e3b9f8da1976dae6e16704a031b359
+ sha256sums = e68c1f328a7d48cf06d27231cfade3c4eb11692076760abd29e7c97595f1c42b
sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
sha256sums = 495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760
diff --git a/PKGBUILD b/PKGBUILD
index 7fd16a4dcd2a..33d3a503688d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"boost016900_serialization.patch"
)
sha256sums=('SKIP'
- '92bf04a12ce6a1f559eb3b129e324e0349e3b9f8da1976dae6e16704a031b359'
+ 'e68c1f328a7d48cf06d27231cfade3c4eb11692076760abd29e7c97595f1c42b'
'4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
'495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760')
diff --git a/python.patch b/python.patch
index 287cbb1c0f68..175f414295e3 100644
--- a/python.patch
+++ b/python.patch
@@ -65,12 +65,13 @@ index 3ac004b2b..b2abe340c 100644
-target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${TBB_LIBRARY} )
+target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} )
diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
-index c8d9c4aa9..1dc6b7c63 100644
+index de4e11ec5..2c7debda4 100644
--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
+++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
@@ -30,4 +30,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
--TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARIES} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
+\ No newline at end of file
++TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})