summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-04-02 17:53:14 +0200
committerbartus2020-04-02 17:53:14 +0200
commita62ae9a036c2af04d338d614c1b889320fa0a221 (patch)
tree8a4aa4793208436e2105a36e8a775f4619d46ae6
parent9c5f2a9524efaf38e89b37921932d987b96edb76 (diff)
downloadaur-a62ae9a036c2af04d338d614c1b889320fa0a221.tar.gz
Update python.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--python.patch29
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551edd7f486b..842996a894ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = luxcorerender-git
pkgdesc = Physically correct, unbiased rendering engine.
- pkgver = 2.3.r534.g71a3bb055
+ pkgver = 2.3.r612.gddce015f7
pkgrel = 1
epoch = 2
url = https://www.luxcorerender.org/
@@ -32,7 +32,7 @@ pkgbase = luxcorerender-git
source = python.patch
source = glfw.patch
sha256sums = SKIP
- sha256sums = 38a12c99020cc293e8198f1b2eaafe95ce0e9e96ffd4abb8dc7396a57140e5b8
+ sha256sums = 4a86c54c1590bc9afecdfd0c61231de24f453e11a6906150a47cbc64888fa86b
sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
pkgname = luxcorerender-git
diff --git a/PKGBUILD b/PKGBUILD
index 23d972e0d91e..531eab7f9100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="luxcorerender"
_ver_tag="luxcorerender_v2.2"
{ IFS='.'; read -r _ver_major _ver_minor; ((_ver_minor++)); unset IFS; } <<<${_ver_tag#luxcorerender_v}
pkgname=${_name}-git
-pkgver=2.3.r534.g71a3bb055
+pkgver=2.3.r612.gddce015f7
epoch=2
pkgrel=1
pkgdesc="Physically correct, unbiased rendering engine."
@@ -25,9 +25,8 @@ source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"glfw.patch"
)
sha256sums=('SKIP'
- '38a12c99020cc293e8198f1b2eaafe95ce0e9e96ffd4abb8dc7396a57140e5b8'
- '4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
-)
+ '4a86c54c1590bc9afecdfd0c61231de24f453e11a6906150a47cbc64888fa86b'
+ '4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1')
pkgver() {
# shellcheck disable=SC2164
diff --git a/python.patch b/python.patch
index 3a2a1c2fcb85..78fec656b917 100644
--- a/python.patch
+++ b/python.patch
@@ -1,5 +1,5 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a4a073f2e..4025bc894 100644
+index 7dda21b7d..fe41ec5d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,10 @@ MESSAGE(STATUS "CMake version " ${CMAKE_VERSION} " detected")
@@ -14,48 +14,49 @@ index a4a073f2e..4025bc894 100644
SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
-index dc3f5d8cf..a8b429814 100644
+index be614b8e8..94918929e 100644
--- a/samples/luxcoreconsole/CMakeLists.txt
+++ b/samples/luxcoreconsole/CMakeLists.txt
@@ -28,4 +28,4 @@ set(LUXCORECONSOLE_SRCS
add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
--TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
\ No newline at end of file
-+TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
-index c140dc23b..c8cba9880 100644
+index 194104caf..241dbd5f2 100644
--- a/samples/luxcoredemo/CMakeLists.txt
+++ b/samples/luxcoredemo/CMakeLists.txt
@@ -29,4 +29,4 @@ set(LUXCORELIBDEMO_SRCS
add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
--TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
-index 90c1967cd..aa024f650 100644
+index 3acb27bfa..b52d3ec81 100644
--- a/samples/luxcorescenedemo/CMakeLists.txt
+++ b/samples/luxcorescenedemo/CMakeLists.txt
@@ -29,4 +29,4 @@ set(LUXCORESCENEDEMO_SRCS
add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
add_definitions(${VISIBILITY_FLAGS})
--TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
+-TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
++TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES} ${CUDA_ALL_LIBRARIES})
diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
-index 33b50b3d0..ba1982a42 100644
+index c8b23001b..607f92b6a 100644
--- a/samples/luxcoreui/CMakeLists.txt
+++ b/samples/luxcoreui/CMakeLists.txt
-@@ -88,4 +91,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
+@@ -90,5 +90,6 @@ TARGET_LINK_LIBRARIES(luxcoreui
${OPENGL_LIBRARIES}
${GTK3_LIBRARIES}
${Boost_LIBRARIES}
+ ${PYTHON_LIBRARIES}
- ${OPENCL_LIBRARIES})
+ ${OPENCL_LIBRARIES}
+ ${CUDA_ALL_LIBRARIES})
diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
-index de4e11ec5..2c7debda4 100644
+index edd6e6762..1875ee5cf 100644
--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
+++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
@@ -30,4 +30,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)