summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-03-17 22:09:54 +0100
committerbartus2020-03-17 22:09:54 +0100
commitbcf014fe7f16caa2c893d80c28e0445fa245a7cb (patch)
tree2120ffbf2269957cce279ae4673dc9eec15b4578
parent35a5153e9ac04aa6ae87cabeba3f28a9a3c4b3e3 (diff)
downloadaur-bcf014fe7f16caa2c893d80c28e0445fa245a7cb.tar.gz
Update python.patch, switch to ninja generator.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
-rw-r--r--python.patch10
3 files changed, 33 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efe28457c46c..04fb6d45b5ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = luxcorerender-git
pkgdesc = Physically correct, unbiased rendering engine.
- pkgver = 2.3.r372.gf49415935
+ pkgver = 2.3.r534.g71a3bb055
pkgrel = 1
epoch = 2
url = https://www.luxcorerender.org/
arch = x86_64
license = Apache
makedepends = boost
- makedepends = git
- makedepends = doxygen
makedepends = cmake
- makedepends = pyside2-tools
+ makedepends = doxygen
+ makedepends = git
+ makedepends = ninja
makedepends = opencl-headers
- depends = openimagedenoise
- depends = openimageio
- depends = boost-libs
+ makedepends = pyside2-tools
depends = blosc
+ depends = boost-libs
depends = embree
depends = glfw
depends = gtk3
depends = opencl-icd-loader
+ depends = openimagedenoise
+ depends = openimageio
optdepends = opencl-driver: for gpu acceleration
optdepends = pyside2: for pyluxcoretools gui
provides = luxrays
@@ -32,7 +33,7 @@ pkgbase = luxcorerender-git
source = glfw.patch
source = boost016900_serialization.patch
sha256sums = SKIP
- sha256sums = e68c1f328a7d48cf06d27231cfade3c4eb11692076760abd29e7c97595f1c42b
+ sha256sums = 38a12c99020cc293e8198f1b2eaafe95ce0e9e96ffd4abb8dc7396a57140e5b8
sha256sums = 4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1
sha256sums = 495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760
diff --git a/PKGBUILD b/PKGBUILD
index d78213c63d10..3406e4c23fb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
+#!/usr/hint/bash
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-# shellcheck disable=SC2034
+# shellcheck disable=SC2034,SC2154 # uninitialized/unused variables.
+
_name="luxcorerender"
_ver_tag="luxcorerender_v2.2"
{ IFS='.'; read -r _ver_major _ver_minor; ((_ver_minor++)); unset IFS; } <<<${_ver_tag#luxcorerender_v}
pkgname=${_name}-git
-pkgver=2.3.r372.gf49415935
+pkgver=2.3.r534.g71a3bb055
epoch=2
pkgrel=1
pkgdesc="Physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
license=('Apache')
-depends=(openimagedenoise openimageio boost-libs blosc embree glfw gtk3 opencl-icd-loader)
+depends=(blosc boost-libs embree glfw gtk3 opencl-icd-loader openimagedenoise openimageio)
optdepends=("opencl-driver: for gpu acceleration"
"pyside2: for pyluxcoretools gui")
-makedepends=(boost git doxygen cmake pyside2-tools opencl-headers)
+makedepends=(boost cmake doxygen git ninja opencl-headers pyside2-tools)
conflicts=(luxrays-hg luxcorerender)
-provides=(luxrays luxcorerender=${epoch}:${_ver_major}.${_ver_minor})
+provides=(luxrays "luxcorerender=${epoch}:${_ver_major}.${_ver_minor}")
options=('!buildflags')
source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"python.patch"
@@ -24,42 +26,41 @@ source=("${_name}::git+https://github.com/LuxCoreRender/LuxCore.git${_fragment}"
"boost016900_serialization.patch"
)
sha256sums=('SKIP'
- 'e68c1f328a7d48cf06d27231cfade3c4eb11692076760abd29e7c97595f1c42b'
+ '38a12c99020cc293e8198f1b2eaafe95ce0e9e96ffd4abb8dc7396a57140e5b8'
'4e04c3eb653f00d2389aff8e7fda2d244e258cbca3a22e32c13388a3984e4bb1'
'495d183aef045e53ec8c53aa08cdcc082fb4e69ccb0857693cb0cf2684db0760')
pkgver() {
- cd ${srcdir}/${_name}
- [ -v _ver_tag ] && printf %d.%d.r%s.g%s $_ver_major $_ver_minor $(git rev-list ${_ver_tag}..HEAD --count) $(git log --pretty=format:'%h' -n 1) \
+# shellcheck disable=SC2164
+ cd "${srcdir}/${_name}"
+# shellcheck disable=SC2015
+ [ -v _ver_tag ] && printf %d.%d.r%s.g%s "$_ver_major" "$_ver_minor" "$(git rev-list ${_ver_tag}..HEAD --count)" "$(git log --pretty=format:'%h' -n 1)" \
|| git describe --long --tags | sed 's/^luxcorerender_v//;s/beta/\.beta/;;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${srcdir}/${_name}
- git apply -v ${srcdir}/*.patch
+ git -C "${srcdir}/${_name}" apply -v "${srcdir}"/*.patch
}
build() {
_pyver=$(python -c "from sys import version_info; print(\"%d%d\" % (version_info[0],version_info[1]))")
- mkdir -p ${srcdir}/build && cd ${srcdir}/build
- cmake -DPYTHON_V=${_pyver} ${srcdir}/${_name}
- make
+ cmake -DPYTHON_V="${_pyver}" "${srcdir}/${_name}" -S "${_name}" -B "build" -G Ninja
+# shellcheck disable=SC2086
+ ninja ${MAKEFLAGS:--j1} -C "build"
}
package() {
- cd ${srcdir}/build
-
- install -d -m755 ${pkgdir}/usr/{bin,include,lib}
- install -m755 bin/* ${pkgdir}/usr/bin
- install -m644 lib/* ${pkgdir}/usr/lib
- cp -a ${srcdir}/${_name}/include ${pkgdir}/usr
- for file in ${pkgdir}/usr/include/*/*.in; do mv $file ${file%.in}; done
+ install -d -m755 "${pkgdir}"/usr/{bin,include,lib}
+ install -m755 build/bin/* "${pkgdir}"/usr/bin
+ install -m644 build/lib/* "${pkgdir}"/usr/lib
+ cp -a "${_name}"/include "${pkgdir}"/usr
+ for file in "${pkgdir}"/usr/include/*/*.in; do mv "$file" "${file%.in}"; done
# install pyluxcore to the Python search path
# _pypath=`pacman -Ql python | sed -n '/\/usr\/lib\/python[^\/]*\/$/p' | cut -d" " -f 2`
- _pypath=`python -c 'import sys;print("/usr/lib/python{}.{}".format(sys.version_info.major,sys.version_info.minor))'`
- install -d -m755 ${pkgdir}/${_pypath}
- mv ${pkgdir}/usr/lib/pyluxcore.so ${pkgdir}/${_pypath}
+ _pypath=$(python -c 'import sys;print("/usr/lib/python{}.{}".format(sys.version_info.major,sys.version_info.minor))')
+ install -d -m755 "${pkgdir}/${_pypath}"
+ mv "${pkgdir}"/usr/lib/pyluxcore.so "${pkgdir}/${_pypath}"
}
# vim:set ts=2 sw=2 et:
diff --git a/python.patch b/python.patch
index 175f414295e3..3a2a1c2fcb85 100644
--- a/python.patch
+++ b/python.patch
@@ -54,16 +54,6 @@ index 33b50b3d0..ba1982a42 100644
${Boost_LIBRARIES}
+ ${PYTHON_LIBRARIES}
${OPENCL_LIBRARIES})
-diff --git a/tests/benchsimple/CMakeLists.txt b/tests/benchsimple/CMakeLists.txt
-index 3ac004b2b..b2abe340c 100644
---- a/tests/benchsimple/CMakeLists.txt
-+++ b/tests/benchsimple/CMakeLists.txt
-@@ -22,4 +22,4 @@ link_directories (${LuxRays_LIB_DIR})
- add_executable(benchsimple benchsimple.cpp)
- add_definitions(${VISIBILITY_FLAGS})
- remove_definitions("-DLUXCORE_DLL")
--target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${TBB_LIBRARY} )
-+target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} )
diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
index de4e11ec5..2c7debda4 100644
--- a/tests/luxcoreimplserializationdemo/CMakeLists.txt