summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-01-08 23:37:35 +0100
committerbartus2021-03-01 11:08:53 +0100
commitd84bc6d1f0769df179c4a7c7869ebe72dd5eb59d (patch)
tree8e82db96209092689d8a7820730034d20efa7acb
parent99f8d94711ee0ab5aa2aa8e9ce72710b4b63ae5f (diff)
downloadaur-d84bc6d1f0769df179c4a7c7869ebe72dd5eb59d.tar.gz
Travis: drop leading zeros to prevent triggering bash octal interpretation.
-rw-r--r--.travis.yml2
1 files changed, 1 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 40d5b7348baa..5e9ff2bed53e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -43,7 +43,7 @@ archlinux:
- |
update_interval=5
update_offset=$(. PKGBUILD; sha1sum <<< "$pkgname"|sed -e "s/[a-z -]//g" -e "s/^0*//"|echo `cat`%$update_interval|bc)
- next_update=$(((365-`date +%j`+update_offset)%update_interval))
+ next_update=$(((365-`date +%-j`+update_offset)%update_interval))
# check (opt|)depends update
- |
build_deps=$(. PKGBUILD; IFS=$'\n'; echo -e "${depends[*]}\n${makedepends[*]}"; )