diff options
author | bartus | 2024-11-23 23:43:24 +0100 |
---|---|---|
committer | bartus | 2024-11-23 23:43:24 +0100 |
commit | fcf60e0c92b9cf5b85041267085207d5a56e8d37 (patch) | |
tree | e7fda65ad935d17a2defc7f43c4c273453e8a35e | |
parent | 33a0e3931022f52379d384ea7d3251d02d85220b (diff) | |
download | aur-fcf60e0c92b9cf5b85041267085207d5a56e8d37.tar.gz |
Update env var configuration
-rw-r--r-- | PKGBUILD | 15 |
1 files changed, 13 insertions, 2 deletions
@@ -1,9 +1,20 @@ #!/hint/bash # Maintainer : bartus <arch-user-repoᘓbartus.33mail.com> -# Configuration -_fragment=${FRAGMENT:-#branch=master} +# ToDo: +# - use system wide libs, add control vars to allow build with bundeled deps + +# Configuration: +# Use: makepkg VAR1=0 VAR2=1 to enable(1) disable(0) a feature +# Use: {yay,paru} --mflags=VAR1=0,VAR2=1 +# Use: aurutils --margs=VAR1=0,VAR2=1 +# Use: VAR1=0 VAR2=1 pamac + +# Use FRAGMENT=#{commit,tag,brach}=xxx for bisect build +_fragment="${FRAGMENT:-#branch=master}" + # shellcheck disable=SC2015 +((DISABLE_CCTAG)) && _use_cctag=OFF || _use_cctag=ON # Disable CCTag (require: cuda) ((DISABLE_OPENCL)) && { CMAKE_FLAGS+=("-DLUXRAYS_DISABLE_OPENCL=ON") } || { |