summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormanjaro2019-05-25 16:09:33 +0200
committermanjaro2019-05-25 18:46:46 +0200
commitfeba749a2c3112063eaabee2b06576cef82bda7f (patch)
tree9246873a5afaf2691891dd7f8b7f5b00cdc0d836
parentf131d765a1801de52091ee6b8de2b0d04b513778 (diff)
downloadaur-feba749a2c3112063eaabee2b06576cef82bda7f.tar.gz
Add Travis Ci build and deploy.
-rw-r--r--.travis.yml37
-rw-r--r--.travis_deploy.sh8
-rw-r--r--PKGBUILD10
3 files changed, 54 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..38c7f8988b4b
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,37 @@
+sudo: required
+
+branches:
+ only:
+ - master
+
+cache:
+ directories:
+ - src
+# - AUR-repo
+
+services:
+- docker
+
+arch:
+ repos:
+# - papyros=http://dash.papyros.io/repos/$repo/$arch
+ - bartus=https://github.com/bartoszek/AUR-repo/raw/master
+ packages:
+ # arch/aur packages
+# - python
+# - perl
+ - python-pyside-tools
+ script:
+# - "sudo pacman -Sy"
+ - "makepkg -s --noconfirm TRAVIS=1"
+
+script:
+- "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+- "ls $(pwd)"
+
+deploy:
+ provider: script
+ script: bash .travis_deploy.sh
+ on:
+ branch: master
+ skip_cleanup: true
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..80cd4b90ceeb
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname*$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname*$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push
diff --git a/PKGBUILD b/PKGBUILD
index ee22f45466a8..b356ff262c74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=luxcorerender-git
pkgver=2.2alpha1.r11.gb1b91b90f
pkgrel=1
-pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
+pkgdesc="LuxCoreRender: a physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
license=('Apache')
@@ -38,6 +38,14 @@ prepare() {
build() {
cd ${srcdir}/LuxCore
mkdir -p build && cd build
+ ((TRAVIS)) && {
+ suppress_warnings="-Wno-implicit-fallthrough -Wno-class-memaccess"
+ CFLAGS="$CFLAGS $suppress_warnings"
+ CXXFLAGS="$CXXFLAGS $suppress_warnings"
+ }
+ msg "cflags=\"$CFLAGS\""
+ msg "cxxflags=\"$CXXFLAGS\""
+
cmake -DPYTHON_V=3 ..
make
}