summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2022-11-26 18:11:08 +0100
committerFabian Maurer2022-11-26 18:11:08 +0100
commit02c1ca911378e2597f2cdee6336bd0ad9fbd9141 (patch)
treef05252a61d5da5be4437fbe6194607bb271df776
parent48a865e795da81d6108af0d8213ae713c1707540 (diff)
downloadaur-02c1ca911378e2597f2cdee6336bd0ad9fbd9141.tar.gz
Fix dependencies for latest luxcorerender
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-dependencies.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a219dd5f517d..ad850c479099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxmark
pkgdesc = OpenCL benchmark tool
pkgver = 4.0alpha1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/LuxCoreRender/LuxMark
arch = x86_64
license = GPL3
@@ -34,6 +34,6 @@ pkgbase = luxmark
md5sums = 2d02d2192f6e0baad6090b0609a31b2f
md5sums = 8726fa90791f5380dd24789b8933141e
md5sums = 6ba9b9888160cc06e3c3644e21d80e5a
- md5sums = 3dba64999e0515e7d9c92ae05f9ca839
+ md5sums = f3dddc1b06b947628ac450994a8ffda2
pkgname = luxmark
diff --git a/PKGBUILD b/PKGBUILD
index 863ed073edfa..f8c6308968c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=luxmark
pkgver=4.0alpha1
_pkgver=543b6780171fc58bf7204b312d94ae8bb5bbef56
-pkgrel=3
+pkgrel=4
pkgdesc="OpenCL benchmark tool"
arch=('x86_64') # because of embree only x86_64 is supported
url="https://github.com/LuxCoreRender/LuxMark"
@@ -16,7 +16,7 @@ md5sums=('4eaccbb6db1eb13d2d06b017224907bd'
'2d02d2192f6e0baad6090b0609a31b2f'
'8726fa90791f5380dd24789b8933141e'
'6ba9b9888160cc06e3c3644e21d80e5a'
- '3dba64999e0515e7d9c92ae05f9ca839')
+ 'f3dddc1b06b947628ac450994a8ffda2')
prepare() {
cd "$srcdir/LuxMark-$_pkgver"
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index 16be01ee7fa6..8c7036c169a9 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -6,7 +6,7 @@ index 4de71e3..d7a0e98 100644
ADD_EXECUTABLE(luxmark WIN32 ${LUXMARK_SRCS})
TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
-+TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3 blosc dl Imath)
++TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3 blosc dl Imath fmt)
if (WIN32)
# This is needed by Boost 1.67 but is not found automatically