summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2023-09-12 21:30:44 +0200
committerFabian Maurer2023-09-12 21:30:44 +0200
commit3b54326c7b9bd53df7414f733277ce4ebc3f1ee0 (patch)
tree9864c061e78ed82a4a0c99932fa319a68b1b270d
parentc43b091b8c11f4a136a861664fa6b7cc42d775d3 (diff)
downloadaur-3b54326c7b9bd53df7414f733277ce4ebc3f1ee0.tar.gz
Fix linking with fmt9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-dependencies.patch5
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07d9d0cc6942..89801a19aeec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxmark
pkgdesc = OpenCL benchmark tool
pkgver = 4.0alpha1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/LuxCoreRender/LuxMark
arch = x86_64
license = GPL3
@@ -35,6 +35,6 @@ pkgbase = luxmark
md5sums = 2d02d2192f6e0baad6090b0609a31b2f
md5sums = 8726fa90791f5380dd24789b8933141e
md5sums = 6ba9b9888160cc06e3c3644e21d80e5a
- md5sums = b1881a4956bcc71a877984b77591f155
+ md5sums = eee0e62eee415390be90bd2071cd22cb
pkgname = luxmark
diff --git a/PKGBUILD b/PKGBUILD
index 9d9254415ea3..e3024c141091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=luxmark
pkgver=4.0alpha1
_pkgver=543b6780171fc58bf7204b312d94ae8bb5bbef56
-pkgrel=5
+pkgrel=6
pkgdesc="OpenCL benchmark tool"
arch=('x86_64') # because of embree only x86_64 is supported
url="https://github.com/LuxCoreRender/LuxMark"
@@ -17,7 +17,7 @@ md5sums=('4eaccbb6db1eb13d2d06b017224907bd'
'2d02d2192f6e0baad6090b0609a31b2f'
'8726fa90791f5380dd24789b8933141e'
'6ba9b9888160cc06e3c3644e21d80e5a'
- 'b1881a4956bcc71a877984b77591f155')
+ 'eee0e62eee415390be90bd2071cd22cb')
prepare() {
cd "$srcdir/LuxMark-$_pkgver"
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index 6fb0d9d5c72b..e6a6bc4bd5f2 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -5,8 +5,9 @@ index 4de71e3..d7a0e98 100644
@@ -115,6 +115,7 @@ set(LUXMARK_SRCS
ADD_EXECUTABLE(luxmark WIN32 ${LUXMARK_SRCS})
- TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
-+TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3.11 blosc dl Imath fmt)
+-TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
++TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS} /usr/lib/libfmt.so.9)
++TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3.11 blosc dl Imath)
if (WIN32)
# This is needed by Boost 1.67 but is not found automatically