summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2019-03-31 22:18:25 +0200
committerFabian Maurer2019-03-31 22:18:25 +0200
commit7fd1d40777b98a6eb7eb9e047ce9f0c5dde5d75c (patch)
tree71210ba28a9d19b8102607c6fdeeece82811794c
parente907af0a890660b641947cae411e3d83d60ad942 (diff)
downloadaur-7fd1d40777b98a6eb7eb9e047ce9f0c5dde5d75c.tar.gz
Update dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--fix-dependencies.patch2
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e808f540cc1e..785917512a60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxmark
pkgdesc = OpenCL benchmark tool
pkgver = 3.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.luxrender.net/
arch = x86_64
license = GPL3
@@ -25,6 +25,7 @@ pkgbase = luxmark
depends = opencl-driver
depends = libbcd
depends = intel-tbb
+ depends = oidn
source = luxmark-3.1-086c23ceefed54be27dfd038be6bc7a33984e75b.tar.bz2::https://github.com/LuxCoreRender/LuxMark/archive/086c23ceefed54be27dfd038be6bc7a33984e75b.tar.gz
source = https://bitbucket.org/luxrender/luxmark/downloads/scenes-v3.1beta3.zip
source = system_scenes.diff
@@ -34,7 +35,7 @@ pkgbase = luxmark
md5sums = 03d3d117dfd2f3a7f825e3ea7b68f045
md5sums = c4a378c08f105a84ef2f792370082cd6
md5sums = 6ba9b9888160cc06e3c3644e21d80e5a
- md5sums = 4efb443e534d07812b17367adb3ffedd
+ md5sums = 600b59d4d15bc62ab6133641d39b70bf
pkgname = luxmark
diff --git a/PKGBUILD b/PKGBUILD
index 80aa1728ad4f..6999e696216f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgname=luxmark
pkgver=3.1
_scenever=3.1beta3
_pkgver=086c23ceefed54be27dfd038be6bc7a33984e75b
-pkgrel=5
+pkgrel=6
pkgdesc="OpenCL benchmark tool"
arch=('x86_64') # because of embree only x86_64 is supported
url="http://www.luxrender.net/"
license=('GPL3')
-depends=('boost-libs' 'embree' 'freetype2' 'freeglut' 'glew' 'opencl-icd-loader' 'libgl' 'libpng' 'openimageio' 'qt4' 'opencl-driver' 'libbcd' 'intel-tbb')
+depends=('boost-libs' 'embree' 'freetype2' 'freeglut' 'glew' 'opencl-icd-loader' 'libgl' 'libpng' 'openimageio' 'qt4' 'opencl-driver' 'libbcd' 'intel-tbb' 'oidn')
makedepends=('cmake' 'boost' 'luxcorerender' 'mesa' 'opencl-headers' 'freeglut' 'eos_portable_archive')
source=($pkgname-$pkgver-$_pkgver.tar.bz2::https://github.com/LuxCoreRender/LuxMark/archive/${_pkgver}.tar.gz \
https://bitbucket.org/luxrender/luxmark/downloads/scenes-v${_scenever}.zip \
@@ -17,7 +17,7 @@ md5sums=('7ca734e249aa630703744ed6c77bb962'
'03d3d117dfd2f3a7f825e3ea7b68f045'
'c4a378c08f105a84ef2f792370082cd6'
'6ba9b9888160cc06e3c3644e21d80e5a'
- '4efb443e534d07812b17367adb3ffedd')
+ '600b59d4d15bc62ab6133641d39b70bf')
prepare() {
cd "$srcdir/LuxMark-$_pkgver"
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index d6f06bae325d..3f8f1f968167 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -36,7 +36,7 @@ index 4043b68..e9041a7 100644
ADD_EXECUTABLE(luxmark ${LUXMARK_SRCS})
TARGET_LINK_LIBRARIES(luxmark ${LUXCORE_LIBRARY} ${SLG_LIBRARY} ${LUXRAYS_LIBRARY} ${EMBREE_LIBRARY} ${Boost_LIBRARIES} ${QT_LIBRARIES} ${QT_QTNETWORK_LIBRARIES} ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_gl_LIBRARY} ${OPENCL_LIBRARIES} ${OPENIMAGEIO_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-+ TARGET_LINK_LIBRARIES(luxmark tbb bcd.a openvdb.a boost_iostreams)
++ TARGET_LINK_LIBRARIES(luxmark tbb bcd.a openvdb.a boost_iostreams OpenImageDenoise)
# This instructs FREEGLUT to emit a pragma for the static version
SET_TARGET_PROPERTIES(luxmark PROPERTIES COMPILE_DEFINITIONS FREEGLUT_STATIC)