summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2021-01-06 05:57:01 +0100
committerFabian Maurer2021-01-06 06:43:17 +0100
commitd2bac2adf4c96aafea44e2140d4dc9b8990930fd (patch)
treeb3056a59dd3abe13077d962a2e5702e26c3c634b
parent5eb2a12ded3e3d6e3f19b5eacca44f8adc4ca980 (diff)
downloadaur-d2bac2adf4c96aafea44e2140d4dc9b8990930fd.tar.gz
Update to 4.0alpha1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--fix-dependencies.patch23
-rw-r--r--system_scenes.diff7
4 files changed, 38 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ce39ca4ad5c..af48efcc7a6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxmark
pkgdesc = OpenCL benchmark tool
- pkgver = 4.0alpha0
- pkgrel = 7
+ pkgver = 4.0alpha1
+ pkgrel = 1
url = http://www.luxrender.net/
arch = x86_64
license = GPL3
@@ -26,16 +26,16 @@ pkgbase = luxmark
depends = libbcd
depends = intel-tbb
depends = openimagedenoise
- source = luxmark-4.0alpha0-3284b97fdea381553d763e4e153f4d29e48ba185.tar.bz2::https://github.com/LuxCoreRender/LuxMark/archive/3284b97fdea381553d763e4e153f4d29e48ba185.tar.gz
- source = scenes_4.0alpha0.zip::https://github.com/LuxCoreRender/LuxMark/releases/download/luxmark_v4.0alpha0/scenes.tgz
+ source = luxmark-4.0alpha1-543b6780171fc58bf7204b312d94ae8bb5bbef56.tar.bz2::https://github.com/LuxCoreRender/LuxMark/archive/543b6780171fc58bf7204b312d94ae8bb5bbef56.tar.gz
+ source = scenes_4.0alpha1.zip::https://github.com/LuxCoreRender/LuxMark/releases/download/luxmark_v4.0alpha1/scenes.tgz
source = system_scenes.diff
source = exepath.diff
source = fix-dependencies.patch
- md5sums = 92862b24a169f54f084c310fdf7e2eb5
- md5sums = 2e17995365617b8af066e5aa2c78df49
- md5sums = c11dd38c085e03ced707410b43a94088
+ md5sums = 4eaccbb6db1eb13d2d06b017224907bd
+ md5sums = 2d02d2192f6e0baad6090b0609a31b2f
+ md5sums = 8726fa90791f5380dd24789b8933141e
md5sums = 6ba9b9888160cc06e3c3644e21d80e5a
- md5sums = 63382377d8f8e0dbfd7c4c816c62d49a
+ md5sums = e04c72ea68fbcdd6b96245935441c9fe
pkgname = luxmark
diff --git a/PKGBUILD b/PKGBUILD
index 1486c608bdb5..ba4248e67d9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabian Maurer <dark.shadow4@web.de>
pkgname=luxmark
-pkgver=4.0alpha0
-_pkgver=3284b97fdea381553d763e4e153f4d29e48ba185
-pkgrel=7
+pkgver=4.0alpha1
+_pkgver=543b6780171fc58bf7204b312d94ae8bb5bbef56
+pkgrel=1
pkgdesc="OpenCL benchmark tool"
arch=('x86_64') # because of embree only x86_64 is supported
url="http://www.luxrender.net/"
@@ -12,11 +12,11 @@ makedepends=('cmake' 'boost' 'luxcorerender' 'mesa' 'opencl-headers' 'freeglut'
source=($pkgname-$pkgver-$_pkgver.tar.bz2::https://github.com/LuxCoreRender/LuxMark/archive/${_pkgver}.tar.gz \
scenes_$pkgver.zip::https://github.com/LuxCoreRender/LuxMark/releases/download/luxmark_v${pkgver}/scenes.tgz \
system_scenes.diff exepath.diff fix-dependencies.patch)
-md5sums=('92862b24a169f54f084c310fdf7e2eb5'
- '2e17995365617b8af066e5aa2c78df49'
- 'c11dd38c085e03ced707410b43a94088'
+md5sums=('4eaccbb6db1eb13d2d06b017224907bd'
+ '2d02d2192f6e0baad6090b0609a31b2f'
+ '8726fa90791f5380dd24789b8933141e'
'6ba9b9888160cc06e3c3644e21d80e5a'
- '63382377d8f8e0dbfd7c4c816c62d49a')
+ 'e04c72ea68fbcdd6b96245935441c9fe')
prepare() {
cd "$srcdir/LuxMark-$_pkgver"
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index 7b8e22a25086..c3ad8998c839 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -2,12 +2,29 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23b2230..c9b1bed 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -102,6 +102,7 @@ set(LUXMARK_SRCS
+@@ -115,6 +115,7 @@ set(LUXMARK_SRCS
ADD_EXECUTABLE(luxmark WIN32 ${LUXMARK_SRCS})
- TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${OPENCL_LIBRARIES})
+ TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
+TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb.a OpenImageIO python3 blosc dl)
+
if (WIN32)
# This is needed by Boost 1.67 but is not found automatically
- TARGET_LINK_LIBRARIES(luxmark bcrypt.lib)
+diff --git a/cmake/Packages/FindOidn.cmake b/cmake/Packages/FindOidn.cmake
+index 3544698..be202b4 100644
+--- a/cmake/Packages/FindOidn.cmake
++++ b/cmake/Packages/FindOidn.cmake
+@@ -14,10 +14,10 @@
+ ## limitations under the License. ##
+ ## ======================================================================== ##
+
+-FIND_PATH(OIDN_INCLUDE_PATH NAMES OpenImageDenoise/version.h PATHS
++FIND_PATH(OIDN_INCLUDE_PATH NAMES OpenImageDenoise/oidn.h PATHS
+ ${OIDN_ROOT}/include)
+ IF (NOT OIDN_INCLUDE_PATH)
+- FIND_PATH(OIDN_INCLUDE_PATH NAMES OpenImageDenoise/version.h PATHS
++ FIND_PATH(OIDN_INCLUDE_PATH NAMES OpenImageDenoise/oidn.h PATHS
+ /usr/include
+ /usr/local/include
+ /opt/local/include) \ No newline at end of file
diff --git a/system_scenes.diff b/system_scenes.diff
index 151350a37f61..88386863d3a0 100644
--- a/system_scenes.diff
+++ b/system_scenes.diff
@@ -1,11 +1,10 @@
diff -rup luxrender-luxmark-985b948aa5c7/src/main.cpp luxrender-luxmark-985b948aa5c7.new/src/main.cpp
--- luxrender-luxmark-985b948aa5c7/src/main.cpp 2015-02-25 10:46:48.000000000 +0100
+++ luxrender-luxmark-985b948aa5c7.new/src/main.cpp 2015-03-12 23:01:53.971856726 +0100
-@@ -159,16 +159,7 @@ int main(int argc, char **argv) {
- return EXIT_SUCCESS;
+@@ -165,15 +165,7 @@ int main(int argc, char **argv) {
else {
- app.Init(mode, devices, scnName, singleRun, singleRunExtInfo);
--
+ app.Init(mode, useCPU, devices, optixDevices, scnName, singleRun, singleRunExtInfo);
+
- // If current directory doesn't have the "scenes" directory, move
- // to where the executable is
- if (!boost::filesystem::exists("./scenes")) {