summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2024-01-31 19:43:14 +0100
committerFabian Maurer2024-01-31 19:43:14 +0100
commitf47d9895e772fa383f6f8216cf9fe9510fa16b9b (patch)
tree1a46418374f9f3da6714255c7f31461c4070f17b
parent3b54326c7b9bd53df7414f733277ce4ebc3f1ee0 (diff)
downloadaur-f47d9895e772fa383f6f8216cf9fe9510fa16b9b.tar.gz
Fix linking with removed fmt9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fix-dependencies.patch4
3 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89801a19aeec..f3f12b19d5f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxmark
pkgdesc = OpenCL benchmark tool
pkgver = 4.0alpha1
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/LuxCoreRender/LuxMark
arch = x86_64
license = GPL3
@@ -35,6 +35,6 @@ pkgbase = luxmark
md5sums = 2d02d2192f6e0baad6090b0609a31b2f
md5sums = 8726fa90791f5380dd24789b8933141e
md5sums = 6ba9b9888160cc06e3c3644e21d80e5a
- md5sums = eee0e62eee415390be90bd2071cd22cb
+ md5sums = fc2ab9d8466290a13a7e40f1e906b04b
pkgname = luxmark
diff --git a/PKGBUILD b/PKGBUILD
index e3024c141091..a1917eee0766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=luxmark
pkgver=4.0alpha1
_pkgver=543b6780171fc58bf7204b312d94ae8bb5bbef56
-pkgrel=6
+pkgrel=7
pkgdesc="OpenCL benchmark tool"
arch=('x86_64') # because of embree only x86_64 is supported
url="https://github.com/LuxCoreRender/LuxMark"
@@ -17,7 +17,7 @@ md5sums=('4eaccbb6db1eb13d2d06b017224907bd'
'2d02d2192f6e0baad6090b0609a31b2f'
'8726fa90791f5380dd24789b8933141e'
'6ba9b9888160cc06e3c3644e21d80e5a'
- 'eee0e62eee415390be90bd2071cd22cb')
+ 'fc2ab9d8466290a13a7e40f1e906b04b')
prepare() {
cd "$srcdir/LuxMark-$_pkgver"
diff --git a/fix-dependencies.patch b/fix-dependencies.patch
index e6a6bc4bd5f2..3d0f6da10444 100644
--- a/fix-dependencies.patch
+++ b/fix-dependencies.patch
@@ -3,10 +3,8 @@ index 4de71e3..d7a0e98 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -115,6 +115,7 @@ set(LUXMARK_SRCS
- ADD_EXECUTABLE(luxmark WIN32 ${LUXMARK_SRCS})
--TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
-+TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS} /usr/lib/libfmt.so.9)
+ TARGET_LINK_LIBRARIES(luxmark ${ALL_LUXCORE_LIBRARIES} ${Boost_LIBRARIES} ${Qt5_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_DL_LIBS})
+TARGET_LINK_LIBRARIES(luxmark opensubdiv.a openvdb opencolorio.a OpenImageIO_Util python3.11 blosc dl Imath)
if (WIN32)