summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-11-07 15:33:02 +0100
committerbartus2018-11-07 15:33:02 +0100
commit65635c8ff9313d739d5f0b9c7546c4be3916f6f7 (patch)
treeb959dfd9d5ca8e32b3f29ae2bcf8a528ca785e87
parent9f770bbc44493fda2bb347dadda5433ae3c6dae4 (diff)
downloadaur-65635c8ff9313d739d5f0b9c7546c4be3916f6f7.tar.gz
fix ambiguous `PyContext` call
revert python35 > python
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ade85da83c1..61f808f9154b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luxrender-hg
pkgdesc = Rendering system for physically correct, unbiased image synthesis
pkgver = 4918+.f56582df55f4+
- pkgrel = 5
+ pkgrel = 6
url = http://www.luxrender.net/
arch = x86_64
license = GPL
@@ -10,7 +10,7 @@ pkgbase = luxrender-hg
makedepends = mesa
makedepends = qt4
makedepends = luxrays-hg
- makedepends = python35
+ makedepends = python
makedepends = opencl-headers
makedepends = eos_portable_archive
makedepends = mercurial
@@ -25,7 +25,7 @@ pkgbase = luxrender-hg
depends = embree-bvh_build-git
optdepends = luxblend25: Blender exporter
optdepends = qt4: Qt GUI
- optdepends = python35: pylux Python interface
+ optdepends = python: pylux Python interface
optdepends = opencl-driver: OpenCL support
provides = luxrender
conflicts = luxrender
diff --git a/PKGBUILD b/PKGBUILD
index ffe30df74f06..381261cd9f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=luxrender-hg
pkgver=4918+.f56582df55f4+
-pkgrel=5
+pkgrel=6
pkgdesc="Rendering system for physically correct, unbiased image synthesis"
arch=('x86_64')
url="http://www.luxrender.net/"
@@ -12,9 +12,9 @@ depends=('boost-libs' 'freeimage' 'openexr' 'openimageio' 'libpng' 'opencl-icd-l
'embree-bvh_build-git')
optdepends=('luxblend25: Blender exporter' \
'qt4: Qt GUI' \
- 'python35: pylux Python interface' \
+ 'python: pylux Python interface' \
'opencl-driver: OpenCL support')
-makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python35' 'opencl-headers'
+makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python' 'opencl-headers'
'eos_portable_archive' 'mercurial')
provides=('luxrender')
conflicts=('luxrender')
@@ -51,6 +51,10 @@ prepare() {
# fix unambiguous 'distance' function in boost/gcc8-stl
patch -Np1 -i ${srcdir}/gcc-8.patch
+
+ # fix unambiguous 'PyContext' both in python3.7 and lux::
+ sed -i 's/\&PyContext/\&lux::PyContext/g' python/pycontext.h
+ sed -i 's/class_<PyContext/class_<lux::PyContext/' python/pycontext.h
}
build() {
@@ -58,7 +62,7 @@ build() {
mkdir -p build
cd build
- _pyver=$(python3.5 -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
+ _pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \