summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2016-11-30 21:37:30 +0100
committerLukáš Jirkovský2016-11-30 21:37:30 +0100
commit890d1e8915c8c20af199390a45f85dd269fb76a9 (patch)
tree5927d5e3a671ec10c2fdb61d6719f01a559171ae
parentbefa55d407042ebf3be358479fbd8ccf4a618fd2 (diff)
downloadaur-890d1e8915c8c20af199390a45f85dd269fb76a9.tar.gz
update dependencies, fix CXX FLAGS
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c7645761f7d..98b1ea109f95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 2 19:38:14 UTC 2016
+# Wed Nov 30 20:37:30 UTC 2016
pkgbase = luxrender-hg
pkgdesc = Rendering system for physically correct, unbiased image synthesis
- pkgver = 4882+.203f2dad3260+
+ pkgver = 4912+.55596283ec1e+
pkgrel = 1
url = http://www.luxrender.net/
arch = x86_64
@@ -14,9 +14,9 @@ pkgbase = luxrender-hg
makedepends = luxrays-hg
makedepends = python
makedepends = opencl-headers
+ makedepends = eos_portable_archive
makedepends = mercurial
depends = boost-libs
- depends = embree
depends = freeimage
depends = openexr
depends = openimageio
@@ -24,6 +24,7 @@ pkgbase = luxrender-hg
depends = libcl
depends = libgl
depends = fftw
+ depends = embree-bvh_build-git
optdepends = luxblend25: Blender exporter
optdepends = qt4: Qt GUI
optdepends = python: pylux Python interface
diff --git a/PKGBUILD b/PKGBUILD
index 7ace26da18d4..731f959780a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=luxrender-hg
-pkgver=4882+.203f2dad3260+
+pkgver=4912+.55596283ec1e+
pkgrel=1
pkgdesc="Rendering system for physically correct, unbiased image synthesis"
arch=('x86_64')
url="http://www.luxrender.net/"
license=('GPL')
-depends=('boost-libs' 'embree' 'freeimage' 'openexr' 'openimageio' 'libpng' 'libcl' 'libgl' 'fftw')
+depends=('boost-libs' 'freeimage' 'openexr' 'openimageio' 'libpng' 'libcl' 'libgl' 'fftw'
+ 'embree-bvh_build-git')
optdepends=('luxblend25: Blender exporter' 'qt4: Qt GUI' \
'python: pylux Python interface'
'opencl-nvidia: OpenCL support for nVidia GPUs' \
'amdapp-sdk: OpenCL support for AMD GPUs' \
'intel-opencl-runtime: OpenCL support for Intel CPUs')
makedepends=('cmake' 'boost' 'mesa' 'qt4' "luxrays-hg" 'python' 'opencl-headers'
- 'mercurial' )
+ 'eos_portable_archive' 'mercurial')
provides=('luxrender')
conflicts=('luxrender')
source=('lux::hg+https://bitbucket.org/luxrender/lux'
@@ -29,7 +30,10 @@ pkgver() {
prepare() {
cd "$srcdir/lux"
+ # force use of python 3 with boost_python
patch -Np1 < "$srcdir/force_python3.diff"
+ # the build requires some extensions
+ sed -i 's|std=c++11|std=gnu++11|' CMakeLists.txt
}
build() {