summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-01-19 21:07:12 +0100
committerChristopher Arndt2016-01-19 21:07:12 +0100
commit253cab3de12ce4fc4a8ad2257d67937eb7d702e1 (patch)
tree924ee5897a300421f2e3574352d8cbabed354217
parent971f3b5012981bd3d945a4abc16cf21d4d7b1b92 (diff)
downloadaur-253cab3de12ce4fc4a8ad2257d67937eb7d702e1.tar.gz
Python 3 can be used to build instead Python 2 now
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eb8f2b8b467..708ac31693b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Jan 19 20:06:30 UTC 2016
pkgbase = lv2-git
pkgdesc = A standard for plugins and matching host applications, mainly targeted at audio processing and generation.
- pkgver = 1.12.0.r984.f18cfa8
+ pkgver = 1.12.1.r1004.4f597a8
pkgrel = 1
url = http://lv2plug.in/
arch = i686
arch = x86_64
license = custom:ISC
makedepends = git
- makedepends = python2
+ makedepends = python
makedepends = libsndfile
makedepends = gtk2
optdepends = libsndfile: example sampler plugin
optdepends = gtk2: example scope plugin
- optdepends = python2: lv2specgen script
- provides = lv2=1.12.0.r984.f18cfa8
+ optdepends = python: lv2specgen script
+ provides = lv2=1.12.1.r1004.4f597a8
provides = lv2core
provides = lv2-svn
conflicts = lv2
diff --git a/PKGBUILD b/PKGBUILD
index 52695f8cc1db..a020ed3d69ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
_pkgname=lv2
pkgname="${_pkgname}-git"
-pkgver=1.12.0.r984.f18cfa8
+pkgver=1.12.1.r1004.4f597a8
pkgrel=1
pkgdesc="A standard for plugins and matching host applications, mainly targeted at audio processing and generation."
arch=('i686' 'x86_64')
url="http://lv2plug.in/"
license=('custom:ISC')
-makedepends=('git' 'python2' 'libsndfile' 'gtk2')
+makedepends=('git' 'python' 'libsndfile' 'gtk2')
optdepends=('libsndfile: example sampler plugin'
'gtk2: example scope plugin'
- 'python2: lv2specgen script')
+ 'python: lv2specgen script')
provides=("${_pkgname}=${pkgver}" 'lv2core' "${_pkgname}-svn")
conflicts=("${_pkgname}" "${_pkgname}-svn")
replaces=('lv2core')
@@ -28,16 +28,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python2 waf configure --prefix=/usr
- python2 waf build $MAKEFLAGS
+ python waf configure --prefix=/usr
+ python waf build $MAKEFLAGS
}
package() {
cd "${srcdir}/${_pkgname}"
- python2 waf install --destdir="$pkgdir"
+ python waf install --destdir="$pkgdir"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # python2 shebangs
- sed -i 's/python/&2/' "$pkgdir/usr/bin/lv2specgen.py"
}