summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-03-18 23:44:55 +0100
committerChristopher Arndt2022-03-18 23:44:55 +0100
commit3e866d493962ef678e5ceb647a28f029376b34ea (patch)
tree985fcd9a61686e69e0cfb9622004a4fb79a24998
parenta8454d4c6dffdbaeedf3d94820ff3d0b84c2a883 (diff)
downloadaur-3e866d493962ef678e5ceb647a28f029376b34ea.tar.gz
Use git tag in pkgver function; remove accidentally commited pkg
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
-rw-r--r--lv2lint-git-0.13.1.r244.29dc320-1-x86_64.pkg.tar.zstbin71134 -> 0 bytes
4 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d442fe5ed493..d1e8bee75269 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lv2lint-git
pkgdesc = Check whether a given LV2 plugin is up to the specification
- pkgver = 0.13.1.r244.29dc320
+ pkgver = 0.14.0.r4.g7fd756b
pkgrel = 1
url = https://github.com/OpenMusicKontrollers/lv2lint
arch = i686
@@ -17,4 +17,3 @@ pkgbase = lv2lint-git
md5sums = SKIP
pkgname = lv2lint-git
-
diff --git a/.gitignore b/.gitignore
index 4b1111ff588b..eb3fcb11d051 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
lv2lint/
src/
pkg/
-lv2lint-git-*.tar.xz
+lv2lint-git-*.pkg.tar.*
lv2lint-git-*.src.tar.gz
.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index 3ea7351ed627..d551226e3655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=lv2lint
pkgname="${_pkgname}-git"
-pkgver=0.13.1.r244.29dc320
+pkgver=0.14.0.r4.g7fd756b
pkgrel=1
pkgdesc="Check whether a given LV2 plugin is up to the specification"
arch=('i686' 'x86_64')
@@ -19,8 +19,10 @@ md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- ver=$(cat VERSION)
- echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
diff --git a/lv2lint-git-0.13.1.r244.29dc320-1-x86_64.pkg.tar.zst b/lv2lint-git-0.13.1.r244.29dc320-1-x86_64.pkg.tar.zst
deleted file mode 100644
index 4100b58813f7..000000000000
--- a/lv2lint-git-0.13.1.r244.29dc320-1-x86_64.pkg.tar.zst
+++ /dev/null
Binary files differ