summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-08-28 22:01:16 +0200
committerChristopher Arndt2023-08-28 22:01:16 +0200
commitae5d9217b2a54f1216e8167e21d884dca3defa28 (patch)
tree83f8f14f14e3c71d358b5f3c31061fb423bf58ba
parent2e4a21591958cabe4a8437fe0115cd2e4e6e2170 (diff)
downloadaur-ae5d9217b2a54f1216e8167e21d884dca3defa28.tar.gz
Upstream repo changed
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
-rw-r--r--lv2lint-BSD-3-Clause.txt11
-rw-r--r--lv2lint-MIT.txt9
4 files changed, 18 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13226171fb74..5d7ab23d3a57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = lv2lint-git
pkgdesc = Check whether a given LV2 plugin is up to the specification (git version)
- pkgver = 0.16.0.r1.g9e5f789
- pkgrel = 2
- url = https://github.com/OpenMusicKontrollers/lv2lint
+ pkgver = 0.16.2.r44.g5f72b03
+ pkgrel = 1
+ url = https://git.open-music-kontrollers.ch/~hp/lv2lint
arch = x86_64
license = Artistic2.0
checkdepends = reuse
makedepends = curl
makedepends = git
makedepends = lilv
+ makedepends = lv2
makedepends = meson
depends = glibc
depends = libelf
provides = lv2lint
conflicts = lv2lint
- source = lv2lint::git+https://github.com/OpenMusicKontrollers/lv2lint.git
- source = lv2lint-BSD-3-Clause.txt
- source = lv2lint-MIT.txt
+ source = lv2lint::git+https://git.open-music-kontrollers.ch/~hp/lv2lint
md5sums = SKIP
- md5sums = 71f739ef75581cae312e8c711bcdab16
- md5sums = 7dda4e90ded66ab88b86f76169f28663
pkgname = lv2lint-git
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index bcec51505327..c7d63ab3dd5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,54 +2,43 @@
_pkgname=lv2lint
pkgname="$_pkgname-git"
-pkgver=0.16.0.r1.g9e5f789
-pkgrel=2
+pkgver=0.16.2.r44.g5f72b03
+pkgrel=1
pkgdesc='Check whether a given LV2 plugin is up to the specification (git version)'
arch=(x86_64)
-url="https://github.com/OpenMusicKontrollers/lv2lint"
+url="https://git.open-music-kontrollers.ch/~hp/lv2lint"
license=(Artistic2.0)
depends=(glibc libelf)
-makedepends=(curl git lilv meson)
+makedepends=(curl git lilv lv2 meson)
checkdepends=(reuse)
provides=($_pkgname)
conflicts=($_pkgname)
-source=("$_pkgname::git+https://github.com/OpenMusicKontrollers/$_pkgname.git"
- 'lv2lint-BSD-3-Clause.txt'
- 'lv2lint-MIT.txt')
-md5sums=('SKIP'
- '71f739ef75581cae312e8c711bcdab16'
- '7dda4e90ded66ab88b86f76169f28663')
+source=("$_pkgname::git+https://git.open-music-kontrollers.ch/~hp/lv2lint")
+md5sums=('SKIP')
pkgver() {
cd $_pkgname
( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long --tags 2>/dev/null | sed -e 's/^v//' -e 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
-prepare() {
- # placate reuse linting
- cp lv2lint-BSD-3-Clause.txt $_pkgname/LICENSES/BSD-3-Clause.txt
- cp lv2lint-MIT.txt $_pkgname/LICENSES/MIT.txt
-}
-
build() {
- cd $_pkgname
- arch-meson -Donline-tests=enabled -Delf-tests=enabled build
- meson compile -C build
+ arch-meson -Donline-tests=enabled -Delf-tests=enabled $_pkgname-build $_pkgname
+ meson compile -C $_pkgname-build
}
check() {
- cd $_pkgname
- meson test -C build
+ meson test -C $_pkgname-build
}
package() {
depends+=(libcurl.so liblilv-0.so)
- cd $_pkgname
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C $_pkgname-build --destdir "$pkgdir"
+ install -vDm 644 $_pkgname/{ChangeLog,README.md,TODO} \
+ -t "$pkgdir"/usr/share/doc/$pkgname
}
# vim:set ts=2 sw=2 et:
diff --git a/lv2lint-BSD-3-Clause.txt b/lv2lint-BSD-3-Clause.txt
deleted file mode 100644
index ea890afbc70c..000000000000
--- a/lv2lint-BSD-3-Clause.txt
+++ /dev/null
@@ -1,11 +0,0 @@
-Copyright (c) <year> <owner>.
-
-Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
-
-1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
-
-2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
-
-3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/lv2lint-MIT.txt b/lv2lint-MIT.txt
deleted file mode 100644
index 2071b23b0e08..000000000000
--- a/lv2lint-MIT.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-MIT License
-
-Copyright (c) <year> <copyright holders>
-
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.