summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-04-15 15:22:18 +0200
committerChristopher Arndt2022-04-15 15:22:18 +0200
commitfbb502b6d9d775f83936fae1a8f7674148f57749 (patch)
tree91078817547be74d3f3879b3af5744e72ab6ff5a
parent3e866d493962ef678e5ceb647a28f029376b34ea (diff)
downloadaur-fbb502b6d9d775f83936fae1a8f7674148f57749.tar.gz
Sync with release package; add check function; fix missing licenses
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD52
-rw-r--r--lv2lint-BSD-3-Clause.txt11
-rw-r--r--lv2lint-MIT.txt9
4 files changed, 66 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e8bee75269..189d8e41d169 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,28 @@
pkgbase = lv2lint-git
- pkgdesc = Check whether a given LV2 plugin is up to the specification
- pkgver = 0.14.0.r4.g7fd756b
+ pkgdesc = Check whether a given LV2 plugin is up to the specification (git version)
+ pkgver = 0.16.0.r1.g9e5f789
pkgrel = 1
url = https://github.com/OpenMusicKontrollers/lv2lint
- arch = i686
arch = x86_64
license = Artistic2.0
+ makedepends = curl
makedepends = git
+ makedepends = lilv
makedepends = meson
- depends = curl
+ makedepends = reuse
+ depends = glibc
depends = libelf
- depends = lilv
provides = lv2lint
conflicts = lv2lint
source = lv2lint::git+https://github.com/OpenMusicKontrollers/lv2lint.git
+ source = lv2lint-BSD-3-Clause.txt
+ source = lv2lint-MIT.txt
md5sums = SKIP
+ md5sums = 71f739ef75581cae312e8c711bcdab16
+ md5sums = 7dda4e90ded66ab88b86f76169f28663
pkgname = lv2lint-git
+ depends = glibc
+ depends = libelf
+ depends = libcurl.so
+ depends = liblilv-0.so
diff --git a/PKGBUILD b/PKGBUILD
index d551226e3655..ad6963ce3d5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,54 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=lv2lint
-pkgname="${_pkgname}-git"
-pkgver=0.14.0.r4.g7fd756b
+pkgname="$_pkgname-git"
+pkgver=0.16.0.r1.g9e5f789
pkgrel=1
-pkgdesc="Check whether a given LV2 plugin is up to the specification"
-arch=('i686' 'x86_64')
+pkgdesc='Check whether a given LV2 plugin is up to the specification (git version)'
+arch=(x86_64)
url="https://github.com/OpenMusicKontrollers/lv2lint"
-license=('Artistic2.0')
-depends=('curl' 'libelf' 'lilv')
-makedepends=('git' 'meson')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/OpenMusicKontrollers/${_pkgname}.git")
-md5sums=('SKIP')
+license=(Artistic2.0)
+depends=(glibc libelf)
+makedepends=(curl git lilv meson reuse)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/OpenMusicKontrollers/$_pkgname.git"
+ 'lv2lint-BSD-3-Clause.txt'
+ 'lv2lint-MIT.txt')
+md5sums=('SKIP'
+ '71f739ef75581cae312e8c711bcdab16'
+ '7dda4e90ded66ab88b86f76169f28663')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
+prepare() {
+ # placate reuse linting
+ cp lv2lint-BSD-3-Clause.txt $_pkgname/LICENSES/BSD-3-Clause.txt
+ cp lv2lint-MIT.txt $_pkgname/LICENSES/MIT.txt
+}
+
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
+ arch-meson -Donline-tests=enabled -Delf-tests=enabled build
+ meson compile -C build
+}
- meson --prefix /usr -Donline-tests=enabled -Delf-tests=enabled build
- ninja -v -C build reconfigure
- ninja -v -C build
+check() {
+ cd $_pkgname
+ meson test -C build
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- DESTDIR="$pkgdir" ninja -C build install
+ depends+=(libcurl.so liblilv-0.so)
+ cd $_pkgname
+ DESTDIR="$pkgdir" meson install -C build
}
# vim:set ts=2 sw=2 et:
diff --git a/lv2lint-BSD-3-Clause.txt b/lv2lint-BSD-3-Clause.txt
new file mode 100644
index 000000000000..ea890afbc70c
--- /dev/null
+++ b/lv2lint-BSD-3-Clause.txt
@@ -0,0 +1,11 @@
+Copyright (c) <year> <owner>.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/lv2lint-MIT.txt b/lv2lint-MIT.txt
new file mode 100644
index 000000000000..2071b23b0e08
--- /dev/null
+++ b/lv2lint-MIT.txt
@@ -0,0 +1,9 @@
+MIT License
+
+Copyright (c) <year> <copyright holders>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.