summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2023-07-29 20:25:05 +0800
committerKuoi2023-07-29 20:25:05 +0800
commita1e34280dc91392b0e3583d504d7539e579e6eff (patch)
tree5fc7f54a30b5ec5b5e84fd7b4e94b6e268d6b118
downloadaur-a1e34280dc91392b0e3583d504d7539e579e6eff.tar.gz
lvb: init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97820a97afa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lvb
+ pkgdesc = parsimony and simulated annealing in the search for phylogenetic trees https://doi.org/10.1093/bioinformatics/btg402
+ pkgver = 4.2
+ pkgrel = 0
+ url = https://github.com/phylolvb/lvb
+ arch = x86_64
+ license = GPL2
+ makedepends = make
+ depends = gcc-libs
+ depends = glibc
+ source = https://github.com/phylolvb/lvb/archive/refs/tags/4.2.tar.gz
+ sha256sums = cdd51333fb82ab4ea356f5bc6cb3dc973d524bfed82cec63db6089f33f494da2
+
+pkgname = lvb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a53180fa0b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Guoyi Zhang <myname at malacology dot net>
+
+pkgname=lvb
+pkgver=4.2
+pkgrel=0
+pkgdesc="parsimony and simulated annealing in the search for phylogenetic trees \
+ https://doi.org/10.1093/bioinformatics/btg402"
+arch=('x86_64')
+url="https://github.com/phylolvb/lvb"
+license=('GPL2')
+depends=('gcc-libs' 'glibc')
+makedepends=('make')
+source=($url/archive/refs/tags/$pkgver.tar.gz)
+sha256sums=('cdd51333fb82ab4ea356f5bc6cb3dc973d524bfed82cec63db6089f33f494da2')
+
+build() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ # example
+ cp -r examples $pkgdir/usr/share/doc/$pkgname/
+ # docs
+ install -Dm 644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
+ # license
+ install -Dm 644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
+ # lib
+ install -Dm 755 libLVB.a $pkgdir/usr/lib/libLVB.a
+ # binary
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+}