summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-10-26 12:07:19 +0800
committerzxp198210052024-10-26 12:07:19 +0800
commit194a1973723ee0dbdd28f22a890655d8f16fb4f1 (patch)
treef5187fadb9846f068808781e37d9a5db82f0926a
parent94f26aeae96f296ed39e92c68b9c0f2f80b79523 (diff)
downloadaur-194a1973723ee0dbdd28f22a890655d8f16fb4f1.tar.gz
update to 0.37.5
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77065c4ad9ad..3e5321b26246 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker.Prebuilt version.Use system-wide electron.
- pkgver = 0.37.2
+ pkgver = 0.37.5
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
- depends = electron31
+ depends = electron32
depends = nodejs
- provides = lvce=0.37.2
+ provides = lvce=0.37.5
conflicts = lvce
options = !strip
options = !emptydirs
@@ -17,11 +17,11 @@ pkgbase = lvce-bin
source = lvce.sh
sha256sums = ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc
sha256sums = 291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980
- source_aarch64 = lvce-0.37.2-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.2/lvce-v0.37.2_arm64.deb
- sha256sums_aarch64 = 2caa21b892a72dbe9beb6821f04b80559571ffc7f76056c7c77e79016f83c7ba
- source_armv7h = lvce-0.37.2-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.2/lvce-v0.37.2_armhf.deb
- sha256sums_armv7h = e65813b0425aba6734dd17e0eb2d6594877474682275a88b400ba2e8890dae8e
- source_x86_64 = lvce-0.37.2-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.2/lvce-v0.37.2_amd64.deb
- sha256sums_x86_64 = 3d017c391e30c69a793bb25690fc48723a04a93a1c95d70cd2923310a4106df4
+ source_aarch64 = lvce-0.37.5-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.5/lvce-v0.37.5_arm64.deb
+ sha256sums_aarch64 = 86a8d3b2136545ce78122a7679b6850899b6b0a76a8cd28815253793b5dd9c2e
+ source_armv7h = lvce-0.37.5-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.5/lvce-v0.37.5_armhf.deb
+ sha256sums_armv7h = ba105c99c2e7cd30832745ba6b17ae9e5c988f2ba82a830ebd2eacd36ddd27f7
+ source_x86_64 = lvce-0.37.5-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.37.5/lvce-v0.37.5_amd64.deb
+ sha256sums_x86_64 = 2573fa50f30337757f2587160cd938e7e60cce3fdad6a42eb2b6e092afb0b271
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1573c2bddfac..e07db5332d22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.37.2
-_electronversion=31
+pkgver=0.37.5
+_electronversion=32
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker.Prebuilt version.Use system-wide electron."
arch=(
@@ -31,9 +31,9 @@ source=(
)
sha256sums=('ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc'
'291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
-sha256sums_aarch64=('2caa21b892a72dbe9beb6821f04b80559571ffc7f76056c7c77e79016f83c7ba')
-sha256sums_armv7h=('e65813b0425aba6734dd17e0eb2d6594877474682275a88b400ba2e8890dae8e')
-sha256sums_x86_64=('3d017c391e30c69a793bb25690fc48723a04a93a1c95d70cd2923310a4106df4')
+sha256sums_aarch64=('86a8d3b2136545ce78122a7679b6850899b6b0a76a8cd28815253793b5dd9c2e')
+sha256sums_armv7h=('ba105c99c2e7cd30832745ba6b17ae9e5c988f2ba82a830ebd2eacd36ddd27f7')
+sha256sums_x86_64=('2573fa50f30337757f2587160cd938e7e60cce3fdad6a42eb2b6e092afb0b271')
build() {
sed -e "
s/@electronversion@/${_electronversion}/g