summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 11:50:43 +0800
committerzxp198210052024-02-26 11:50:43 +0800
commit46bc6fefa7615874d05e35ec688ce1667323a049 (patch)
tree1bc0613fb109dbb7ceeffc721dd32f3bf704b8ba
parent4f5cd4a6c181dc6bedfee6b446120b5bb2fc7e3c (diff)
downloadaur-46bc6fefa7615874d05e35ec688ce1667323a049.tar.gz
update to 0.24.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8986f7cd24ba..927db63b7ac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.23.3
- pkgrel = 2
+ pkgver = 0.24.1
+ pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
arch = armv7h
@@ -9,18 +9,18 @@ pkgbase = lvce-bin
license = MIT
depends = electron28
depends = nodejs
- provides = lvce=0.23.3
+ provides = lvce=0.24.1
conflicts = lvce
options = !strip
source = lintian-lvce
source = lvce.sh
sha256sums = ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc
sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
- source_aarch64 = lvce-0.23.3-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_arm64.deb
- sha256sums_aarch64 = 02a3fabb2be633e62f5d7f35585458c4f2b965830cfe6797b69fd2a7f142f6df
- source_armv7h = lvce-0.23.3-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_armhf.deb
- sha256sums_armv7h = bc4c647171eb340ab295f14adf9570bcd4e8232a0288f10e389f53c519c79b35
- source_x86_64 = lvce-0.23.3-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_amd64.deb
- sha256sums_x86_64 = 1847caecfbb593e241aa520ea452ece04abbcea1b7b86c60d2588146cd388675
+ source_aarch64 = lvce-0.24.1-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.1/lvce-v0.24.1_arm64.deb
+ sha256sums_aarch64 = 7086e15d61d158c73a44548487379afa53f252e94a43d8c190ce310077fc86c8
+ source_armv7h = lvce-0.24.1-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.1/lvce-v0.24.1_armhf.deb
+ sha256sums_armv7h = 8fa6da5b1ba8e199b0bf2501b540cd25c1029bca3451c1e09ba08adf9ec36e6c
+ source_x86_64 = lvce-0.24.1-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.1/lvce-v0.24.1_amd64.deb
+ sha256sums_x86_64 = 08ec11a82d72e72137fc608437a11cc4d2086fdd97f1429c75890b6daedf9522
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 50e6c4f7bf13..5d71a5fabaf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.23.3
+pkgver=0.24.1
_electronversion=28
-pkgrel=2
+pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=(
'aarch64'
@@ -28,9 +28,9 @@ source=(
)
sha256sums=('ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc'
'0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
-sha256sums_aarch64=('02a3fabb2be633e62f5d7f35585458c4f2b965830cfe6797b69fd2a7f142f6df')
-sha256sums_armv7h=('bc4c647171eb340ab295f14adf9570bcd4e8232a0288f10e389f53c519c79b35')
-sha256sums_x86_64=('1847caecfbb593e241aa520ea452ece04abbcea1b7b86c60d2588146cd388675')
+sha256sums_aarch64=('7086e15d61d158c73a44548487379afa53f252e94a43d8c190ce310077fc86c8')
+sha256sums_armv7h=('8fa6da5b1ba8e199b0bf2501b540cd25c1029bca3451c1e09ba08adf9ec36e6c')
+sha256sums_x86_64=('08ec11a82d72e72137fc608437a11cc4d2086fdd97f1429c75890b6daedf9522')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \